13

Is there any way to change the default printing settings in the dialog box?

For instance, I would like the paper format to be always A4. Now it always appears as US letter by default and I have to change it each time.

3
  • What Ubuntu release are you using? But you can do that from the printer properties page.
    – Mitch
    May 17 '13 at 11:09
  • 12.04. I went to all settings -> printers but there wasn't anything about this. Did I look in the wrong place? I don't see anything else about printing in the settings May 17 '13 at 12:24
  • @RickyRobinson did it work?
    – Salem
    May 20 '13 at 21:08
17

You can use Cups administration page. You can access it by opening http://localhost:631 in your web browser.

Then select Administration -> Manage Printers

enter image description here

Select your printer and then, on the "Administration" dropbox choose "Set Default options". Change the default settings and finally press "Set default options". If it asks you the username/password use the same combination you use to login.

enter image description here

3
  • 1
    Wow, this thing was extremely well hidden. Thanks! May 21 '13 at 8:25
  • @Salem I get "Unauthorized", and it asks me to enter username and password with no form fields. Jan 7 '20 at 17:43
  • You need to add your username to the lpadmin group. Dec 19 '20 at 9:46
1

Via Ubuntu settings

On Ubuntu 20.04.1 LTS the settings can normally be set via

Settings --> Printers -->
PrintingOptionsDropdown

But they don't always seem to take effect or perhaps there is another configuration conflicting which takes precedence.

Via CUPS server

Salem in his answer describes how to access the CUPS server via web-browser.

This server can also be accessed under

Settings --> Printers --> Select Additional printer settings AdditionalPrinterSettings

A GUInterface of the connection to the local host server will appear enter image description here

Right click on the printer of interest and select properties, etc, etc..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.