I've been trying for two days now to get my computer running the NVidia drivers. I'm running a GTX 680 and 64 bit architecture.

I've tried multiple things, here's a few:

The Additional Drivers tab shows nothing, but I have used sudo apt-get install nvidia-current and pretty much every other nvidia package I could find using apt-cache search nvidia

I've downloaded the .run file from NVidia's website, and logged out, started a VTY session, stopped lightdm, installed it, and rebooted, multiple times.

No matter the approach, the outcome seems to be the same. The system boots, I can hear the splash screen, where I am supposed to log in, but the screen is black, and backlight is off. I can't get into any VTY session like that, I have to reboot and add nomodeset to the boot options. I still get a black screen when I let it go to the login screen, but I can get in a VTY session. Regardless, I have yet to be able to fix it.

Edit 1

Not sure of the importance, but I am running a 2560x1600 native resolution monitor, if that somehow plays into it at all.

  • Isn't that an Nvidia Optimus system? – grimpitch May 16 '13 at 21:08
  • I have no clue. I've tried so many different installation methods. I chose GeForce->680 (not M)->Linux 64 and used that .run file. – Robert May 16 '13 at 21:23
  • Run lspci and look for the VGA controllers. Is there only the Nvidia? – grimpitch May 16 '13 at 21:28
  • This is the output from lspci pastebin.com/2G9hTXx5 – Robert May 16 '13 at 21:35
  • Is this a desktop system with the Nvidia card in an expansion slot or a laptop? I don't think that the resolution would be the problem. – grimpitch May 16 '13 at 21:46

The NVIDIA card is connected to a 27" monitor made by Catleap. It doesn't communicate it's capabilities well through EDID, and xserver can't work out what resolution and refresh rate to use. The following xorg.conf solves the problem:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 313.30  (buildmeister@swio-display-x86-rhel47-05)  Wed Mar 27 16:37:22 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       88.8
    VertRefresh     59.5
    Option         "DPMS"
    Modeline       "2560x1440_60.00" 241.50 2560 2608 2640 2720 1440 1443 1448 1481 +HSync -VSync
    DisplaySize    597 336

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option         "UseEDID" "False"
    Option         "UseEDIDDPI" "False"
    Option         "UseEDIDFreqs" "False"
    Option         "ExactModeTimingsDVI" "True"
    Option         "metamodes" "2560x1440_60 +0 +0"
    SubSection     "Display"
        Depth       24

there is only one way I succeeded for Ubuntu 13.04 and lucky you, it is very easy :)

1st Download driver on nvidia website : NVIDIA-Linux-x86_64-319.17.run (It was this in my case)

2nd Create /etc/modprobe.d/nvidia-graphics-drivers.conf and write inside

blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
blacklist nvidia-current
blacklist nvidia-173-updates
blacklist nvidia-96-updates
alias nvidia nvidia_current_updates
alias nouveau off
alias lbm-nouveau off

3rd Reboot

4th It will reboot in low resolution but it is fine for now.

  1. Press CTRL+ALT+F2 and login

  2. Go in the folder where you have downloaded NVidia Driver ie 'cd Downloads'

  3. sudo chmod +x NameOfFileDriver.run

  4. sudo service lightdm stop

  5. ./NameOfFileDriver.run --> It will run the install :)

  6. Type reboot :D


if you are already stuck on similar pb, i posted an answer that seems to fixed this for me there : Installing NVIDIA GeForce GTX 560 on Ubuntu 13.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.