This afternoon I updated from 12.10 to 13.04. Ubuntu 12.10 worked entirely fine. However, when I now try to start Ubuntu 13.04, my graphics go completely wrong. And when I mean wrong, I mean really totally wrong: I get to see the ubuntu splash screen, but whenever it should get to the login screen I get white noise. If I boot in recovery mode, and then hit "resume", it doesn't change anything; still the unworkable white noise.

I can get something sort of workable by booting up an older version of the kernel. Whereas version 3.8.0 gives me the white noise, kernel version 3.2.40 allows me to login normally. However, even there, the unity and top bars covered in some kind of noise. See the image for a screenshot. And if I click the dash button, my screen goes totally berzerk again. enter image description here

Someone somewhere suggested installing fglrx-updates (as I am using an ATI Mobility Radeon HD 4530/4570/545v card), but this only aggravated the problem; tiling windows no longer worked and the unity bar disappeared alltogether. This led me to believe it is somehwere related to my graphics card/driver. I tried to uninstall everything fglrx-related, by following the instructions here and here. This reverted my situation back to the one as seen in the image - sort of workable, but very very ugly - and still only in the older kernel version.

I then tried installing the gnome shell, but this also had quite some graphical errors. If I go to Software & Sources, I get no suggestions for proprietary drivers at all. Something is wrong with my graphics card/driver, but I don't know what :-(.

If someone could point me in the right direction as how to fix this, thanks a lot!


I was able to fix this by installing the fglrx-legacy PPA downloadable here Now everything runs fine :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.