I have a problem where a one-pixel high white line is displayed through certain letters of text. Almost always only a single character type is affected at once, and only in one font size (though that size can change over time). Most of the time things are fine, but this happens several times a day. It happens frequently in Firefox, but system dialogs, menus, etc. can also be affected. It's been happening ever since I upgraded to 10.10. Only restarting seems to fix it.

Two examples (in the first, only the larger "r" is corrupted): rs


Any help would be appreciated, thanks.

Edit: I've since noticed that I can (sometimes) make the fonts appear correctly by zooming in/out all the way and returning to the default in Firefox (one or two steps, then going back, does nothing) seems to make the problem go away temporarily.

Edit 2: I figure it's worth noting that the solution below doesn't fully work for me any longer (I'm now using Ubuntu 11.10). It does significantly reduce the frequency of this problem occurring.

Edit 3: Still around in 12.04. The fix provided by Vanni works perfectly now for me, but apparently doesn't for some.

Edit 4: This seems to be an xorg problem, with Vanni's answer fixing it for many Intel video cards. I've had this occasionally happen with AMD graphics cards in 13.10 and 14.04, but very rarely (only two or three times).

  • @ Edit 3: I can confirm that on Precise it mostly works, but sometimes doesn't / stops working. No idea why; but it happens so rarely and goes away after re-booting (or maybe even after stand-by ?) that it's o.k. For Raring it might not be an issue anymore. Jul 18, 2013 at 17:31
  • Lately it happens much more often; dunno why... quite a nuisance! Jul 25, 2013 at 9:53
  • My guess is that it depends on the video card. I switched to different laptop a while ago, and have not had this problem in 12.04 through 13.10. Though that doesn't explain why it would happen more and more frequently on a single computer.
    – Fern Moss
    Mar 9, 2014 at 23:06

3 Answers 3


Probably related to this xserver-xorg-video-intel bug on Launchpad.


  1. Open a terminal (CTRL+ALT+t);
  2. type sudo gedit /etc/xorg.conf and hit ENTER;
  3. type your user password and hit ENTER;
  4. copy & paste this into the just opened (hopefully empty) gedit window:

    Section "Device"
        Identifier "Intel"
        Driver "intel"
        Option "DebugWait" "true"
  5. save the file and close gedit;
  6. restart the PC (or restart X).

Hope it works for you too.

  • Thank you. I finally followed your instructions about a week ago, and have yet to see any corruption at all!
    – Fern Moss
    Jul 11, 2011 at 21:50
  • @Aibara Iduas: you're welcome! :) Jul 11, 2011 at 21:58
  • Lately the problem crops up inspite of implementing your answer. Any ideas if there's a new/updated/better solution out there (in mid-2013) ? Jul 25, 2013 at 9:54

I have also had this problem since 10.10. For some reason I don't get it as frequently any more. I recently upgraded to Natty alpha 3 and the problem still occurs with that. I have seen it happen in Firefox, including in this very text box! I have also seen it in window titles - anything that uses the Ubuntu font. I have only seen this problem since 10.10 and the Ubuntu font.

The only thing I can find on the web about this problem is here. I haven't tried that solution yet - if you try it let me know if it works!

  • Hmm, I have an Intel 945GM on my laptop, so maybe it is the same problem. I'd like to try changing the X.org drivers, but I'm really not sure how to go about doing so (and somewhat fearful). Do you know how? Also it definitely affects other fonts, at least for me, not just the official Ubuntu one.
    – Fern Moss
    Mar 12, 2011 at 3:11

Finally a screenshot that looks familiar.

Had this issue for donkey's years (ok, to be fair, since starting to use ubuntu with karmic); it still is present in natty.

Have been ignoring it, as google didn't return sth useful... and it is O.K. - makes for an interesting read sometimes: deciphering text...

I'm privvy to neither cause nor solution, but eager to finally solve it.



I think slash hope the issue is SOLVED (for me / on my system // and for you too of course):

simply uninstalled ttf-mscorefonts-installer !!!

gosh - had I only known earlier... all these years...

Edit n°2

I'm sorry to say: I think the issue remains after all; it seems slightly better; but I still occasionally get single characters with white lines; both in FF and Ubuntu in general; on the current page "g" and "(" have white lines; in Ubuntu "D" had one a minute ago.


Issue remains _unsolved_ (for me).

Not the answer you're looking for? Browse other questions tagged or ask your own question.