I have a hybrid laptop Lenovo T420. I have disabled Optimus in BIOS and I'm only using discrete graphic (Nvidia) now. My Nvidia GFX worked before I upgraded to Ubuntu 13.04, but now the driver wont load.

I tried reinstalling the 'nvidia-current' driver with:

sudo apt-get remove --purge nvidia-*
sudo apt-get install nvidia-current nvidia-settings


$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [Quadro NVS 4200M] (rev a1)

$ uname -a
Linux laptop 3.8.0-21-generic #32-Ubuntu SMP Tue May 14 22:16:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ lsmod | grep -i nvidia 

Any clue on how to move on with this?

  • Does Unity still load or are you dropped in a commandline? – stommestack May 16 '13 at 17:17
  • No Unity bar does not load. I boot op and come into the desktop. – user151515 May 17 '13 at 7:12

try a newer version of the driver, i not sure about 304-version as in current does support your video-card.

sudo apt-get install nvidia-310 nvidia-settings-310

or try latest 313

sudo apt-get install nvidia-313-updates nvidia-settings-313-updates

which both should be in the 13.04 repositories.

or use stable mein drivers from x-updates ppa:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates sudo apt-get update

and install latest drivers from this ppa

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.