I have serached around, but no fix could help me. Here's what happened:

A few days ago, for no reason, I couldn't see the login screen on my Ubuntu 12.04. nor do anything but reboot using CTRL+ALT+DEL. After reading some suggestions and experimenting, this is what I got so far:

  • If I go to the recovery mode and then choose "resume normal boot" I can see the boot up text, and it stops at "Checking battery state".
  • If I choose "failsafe graphics mode" it stops on a different point, one of the last messages being from xserver saying "fatal server error no screens found"
  • I realized that I can get to the desktop if when the black screen appears I use CTRL+ALT+F1 and blindly type my username and password, and then use "startx". I get to my desktop, but no menus at all. At least I can use the terminal this way.
  • I tried reinstalling xorg and nVidia drivers (using the current ones) but it didn't help
  • I deleted the ~/.config/monitors.xml and ~/.config/monitors.xml~ but that only got my resolution to reset to the default one AFTER blind login and use of startx

Any suggestions, anyone? Any logs I need to provide you with?

I would like to note an important piece of info: I had my GeForce 6600GT and then upgraded to GeForce 8800GT. IT died after like three weeks, and then I put back my old 6600GT. It worked fine the first day, so I was thinking if it's possible to install OLDER nVidia drivers (like version 220.xx), using the terminal, could that help? And how do I do that?

Thanks in advance!

UPDATE: I managed to try all the driver versions available in "Additional Drivers" but none helped. Still, the only way to access the desktop is via startx and no menus are shown.

  • I had this problem with ATI drivers what I did was purged them and rebooted and unity -reset – user241453 Apr 1 '14 at 6:17

This is what helped in the end: I removed lightdm and installed GDM. After reboot, it worked:

  • When the HDD stops loading and the black screen appears, type CTRL+ALT+F1
  • Type your username and password in the terminal prompt. If you can't even see it, like I couldn't, type your username, press ETNER, then type the password, press ENTER.
  • Start XORG by typing startx
  • When the desktop appears, open terminal using CTRL+ALT+T
  • Remove lightdm using sudo apt-get remove lightdm
  • Wait for it to finish, then install GDM using sudo apt-get install gdm
  • After it's done, use sudo reboot to restart the computer and GDM should be working

Does anyone know what caused this out of the blue and will I be able to use lightdm again?

| improve this answer | |
  • 1
    I had a similar hangup when booting Ubuntu 13.04 64bit. I followed this procedure and it saved the day for me. – ddoxey Aug 10 '13 at 7:28
  • This didn't work entirely for me (Ubuntu 13.10 64bit) but what did was reinstalling lightdm after the removal step. – user248322 Feb 14 '14 at 23:54
  • I tried to change to gdm and now I can't even access the login screen. – stidmatt May 22 '17 at 16:31
  • what if the desktop doesn't appear after startx? – Sadik Jun 13 '17 at 9:51

did whatever Tesla said but instead of installing GDM simply reinstalled lightdm after removing it:

sudo apt-get install lightdm

This helped solve the problem for me

| improve this answer | |
  • 1
    In the end I ended up installing lightdm again as I figured out that the bug was initiated after editing the xorg.conf file to stop my monitor from switching to the native resolution on boot (which was too high for my GPU at the time). – Tesla Mar 7 '14 at 13:57

I had a similar problem after upgrading from 12.04 LTS to 12.10. The system in question happens to be a Virtualbox VM (guest).

What solved the problem for me was to remove all the Virtualbox guest additions, reboot, then re-install the guest additions.

To remove the guest additions from the command line:

sudo apt-get remove virtualbox-guest-additions
sudo apt-get remove virtualbox-guest-dkms
sudo apt-get remove virtualbox-guest-utils
sudo apt-get remove virtualbox-guest-x11

(Don't worry if you don't have some of those installed. However, if you have none of those installed then you don't have the same problem I did.)

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.