EDIT: Updating to Ubuntu 13.10 solved this issue for me out of the box.

I'm trying to get some control over the brightness of my Samsung QX411 (Integrated Intel graphics) on Ubuntu 3.04 (though I have the exact same issue on 12.04 and on Mint)

Using FN+up/down lowers the screen brightness from max to one peg down or back up. If I try to bring the brightness down any more, it flickers but stays the same.

I have full control of the brightness in Settings, but that's delicate and gets reverted to full max if I open up the brightness settings again, use fn+up/down, the screen goes into power saving, or after log out.

The closest I got was adding


to a line in /etc/default/grub, [source]

I could consequently lower the brightness a couple of pegs down to the minimum with FN+down, but then it's as if the problem got inversed, and I'd get stuck in the bottom tier, I could only increase the brightness by one peg and back down. Rebooting would revert to max brightness.


acpi_osi=, acpi_osi=Linux, acpi_osi=vendor, acpi_osi='!Windows 2012', acpi_backlight=Linux, acpi_backlight='!Windows 2012'

instead didn't do anything for me.

I've also tried adding

echo 2000 > /sys/class/backlight/intel_backlight/brightness to /etc/rc.local,

where my max value from cat /sys/class/backlight/intel_backlight/brightness is 4648, which didn't do anything. (same result with echo 2000 > /sys/class/backlight/acpi_video0/brightness) source

Samsung tools also didn't help in this regard.

I've spent days on this, it's getting quite frustrating. Any help would be greatly appreciated.

2 Answers 2


I had a lot of trouble with my Intel integrated graphics card also, until I made a very minor tweak. In terminal, do:

sudo nano /etc/default/grub

Then go down to find these two lines:


GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""

Notice the addition of backslashes (escape sequences) and quotes... try to copy that line in there exactly as it is above. Also, were you performing, in terminal:

sudo update-grub

After every change you made? If not, that may have something to do with why you never saw a change or difference.

EDIT: Brightness controls stopped working after update on a Samsung QX412-S01AU

This user says that this fixed it for him, exactly as he wanted, for almost the same model laptop (Samsung vendor apparently only):

GRUB_CMDLINE_LINUX_DEFAULT="nosplash acpi_osi=Linux acpi_backlight=vendor"

In version 3.2.0-27 and perhaps a few versions after, you needed this (only try this if the above does NOT work):

GRUB_CMDLINE_LINUX_DEFAULT="nosplash acpi_osi="

After making the changes, do:

sudo update-grub

Of course, reboot once more, and test again, although... you may also want to un-do any changes you manually made to brightness setting files, hoping you made backups. They could potentially contribute to this not being corrected as it was for the user above.

  • Thanks for the suggestion, but unfortunately - no change. Yes I've been update-grub(ing) after every change. I just tried your suggestion and various variations, and the only one that affects brightness control (I can lower but not raise again, as descirbed above) is if I have acpi_backlight=vendor in there.
    – Adam
    May 16, 2013 at 14:08
  • You did try it without the acpi_backlight=vendor setting (as I noted above) and with the additional backslashes/quotes also? When I used the 'vendor' option, it broke my brightness controls in that they ended up being limited. Only when I took out the acpi_backlight=vendor did it begin working.
    – gravity
    May 16, 2013 at 14:14
  • Yes yes, I did, the result was: stuck on max brightness as originally. From all the combinations I tried, if there's no vendor --> stuck on max brightness. If I include vendor --> starts off max brightness, lower brightness, stuck on low brightness.
    – Adam
    May 16, 2013 at 14:29
  • I did a little more searching and appended what appears to be the final 'solution' for another person on these forums. Try that suggestion there, and let us know if it still doesn't work
    – gravity
    May 16, 2013 at 15:12
  • Damn, that looked very promising since the symptoms in that post are identical to mine. Unfortunately neither worked. First one gave me the limited lower brightness options, the second one stuck at max.
    – Adam
    May 16, 2013 at 17:05

Updating to Ubuntu 13.10 solved this issue for me out of the box. It doesn't seem to be the updated kernel that fixed it, as the issue still exists on my Arch install with the latest kernel installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.