i had windows 8 installed in partition C (I had 4 partition).

i installed ubuntu 12.04 amd 64 bit. after completion, i had to restart it. after restart i can't see the dual boot option.

i try to follow some advices in this forum but none worked. one of them was i try to repair using boot repair by following this procedure: 1. sudo add-apt-repository ppa:yannubuntu/boot-repair 2. sudo apt-get update 3. sudo apt-get install -y boot-repair

the result is http://paste.ubuntu.com/5669675/

please help


I didn't see you mention whether you set your systems BIOS to a NON UEFI state, if UEFI applies to your particular system.

FWIW, UEFI and Microsoft's fragile boot loader is a good reason to install LINUX onto USB media since it is well suited for it and avoids issues with Microsoft's bitchy and increasingly selfish versions ever since Fista.


The problem is almost certainly that you have an EFI boot partition that your system is booting from, and you either haven't installed an EFI version of GRUB for Ubuntu or you have, but it hasn't been selected properly in your UEFI setup.

(Another point that may not be obvious: you'll have to disable secure boot in your UEFI setup, too.)

Windows 8 will always install an EFI boot partition to boot from if it detects that your system supports it. Ubuntu may install an MBR (master boot record) instead, which is the non-EFI way of booting. New UEFI BIOSes are capable of booting from either an MBR or an EFI boot partition. If yours is booting to the EFI boot partition, it is probably seeing Windows 8's entry in there but not Ubuntu's. If, however, you do have an MBR and you convince it to boot to the MBR (which is usually just indicated by not having "(EFI)" next to the boot option), then it may boot to an MBR Grub menu but then you won't be able to load Windows 8 from there.

Unfortunately this is a difficult problem to solve but in short, it involves installing grub-efi (if you aren't already using it, and you may be) and either using your motherboard's built-in boot manager (press F12 when booting, usually) or putting the correct information for your Windows boot entry into your Grub menu so you can use Grub to choose. The latter is often a manual operation at the moment.

Various solutions exist here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.