43

I have removed the overlay scrollbars.

How can I configure GTK3 scrollbar clicking behavior?

GTK3 applications scrollbars behave strangely under Ubuntu 12.10 and 13.04. This also happens with Fedora 17 and 18.

When I left-click anywhere above or below the thumb, it jumps to that position and starts dragging from there. The expected behavior is to scroll one page up or down.

When I right-click anywhere above or below the thumb, it scrolls one page up or down. That is the behavior I expect from left-clicking, the same way it works on GTK2 and QT applications.

Horizontal scrollbars have the same problem.

This is very bad for consistency.

  • 1
    You could try setting the scrollbar behaviour back to GTK2 with the following environment variable: LIBOVERLAY_SCROLLBAR=0. – Glutanimate May 16 '13 at 0:54
  • Thanks, this has been driving me insane ever since Firefox switched to gtk3. – sarnold Jul 21 '16 at 18:51
45

Found the answer here:

https://forums.gentoo.org/viewtopic-t-948904-start-0.html

Edit (or create) the file:

~/.config/gtk-3.0/settings.ini

And add the following:

[Settings]
gtk-primary-button-warps-slider = false
  • 3
    Thank you, this was very helpful. I only use 2 or 3 gtk based applications, and having scrollbar behave differently in those than in all other applications was driving me nuts. – Jan Hlavacek Jun 6 '13 at 2:04
  • 1
    Doesn't work for GTK apps in KDE for me. Setting the property in /etc/gtk-3.0/settings.ini works for some applications but not all. – musiKk Apr 7 '15 at 8:21
  • 3
    Works, this will fix GTK3 applications like gedit. It's sad that those config hacks are necessary to stop one of the most basic gui features (which have worked perfectly for decades) from misbehaving. – basic6 Jan 8 '16 at 12:49
  • 7
    What genius thought up this "feature?" Middle-click already skips to the point clicked, and was broken by this. fix_broken_scroll_bar=true – Gringo Suave May 1 '16 at 4:10
  • I'd like to implement the solution but I don't know how and where to edit (or create) the file ~/.config/gtk-3.0/settings.ini. Can you tell me what I have to do? – Thierry Msika May 17 '16 at 12:46
4

For GTK2 applications, I also noticed the scrollbar-warp behavior happens with the Adwaita theme (but not with the Greybird theme). I fixed it for GTK2 by editing /usr/share/themes/Adwaita/gtk-2.0/gtkrc and changing the line

gtk-primary-button-warps-slider = 1

to

gtk-primary-button-warps-slider = 0

1

The behavior appears tied to the desktop theme/style you select. If you install the gtk2-engines-xfce package and then select one of the GTK2 themes (e.g. Xfce-4.0) from the Appearance settings, you will get GTK2-style scroll bars.

Unless you are particularly interested in using Adwaita or Greybird, I think the best (and certainly easiest) solution is just to pick a different theme.

0

Reverting to the Gtk2 scrollbar behavior can also be done on a per-theme basis by creating/including in the ~/.themes/myThemeName/gtk-3.0/settings.ini file, the [Settings] section, the scrollbar behavior switch

[Settings]
gtk-primary-button-warps-slider = false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.