5

I am enjoying libreoffice 4, but don't want to have presenter console on because we do multiple things during a presentation, and the console window blocks out any option for switching windows or system volume or other simple things like seeing the time. I have been down the road of "extensions" but it is built into the core of libreoffice 4 and cannot be just unticked in the tools extensions menu. How do I remove, or at very lease disable it? It seems many other people want to know.


It seems this is renamed in libreoffice 4.1 (or its a kubuntu issue) to libpresenterconsole.so Make sure you are renaming the right thing.

  • 1
    The solution to rename the file works like a charm! Just would like to add a comment that for Libre Office Version: 4.2.1.1 on Ubuntu, the file has been renamed to and located in /opt/libreoffice4.2/program/libPresenterScreenlo.so – user269368 Apr 16 '14 at 2:08
4

I think the easiest and cleanest way to proceed is to go to Tools/Options/Impress/General and disable the option "Enable Presenter Console".

NB: You must be in LibreOffice Impress for this option to show up.

1

It seems that the console script is burried in the core of libreoffice 4, so upon a quick search of the filesystem for "presenter" I found "PresenterScreen.uno.so" in the /usr/lib/libreoffice/program folder. A simple renaming of that file to PresenterScreen.uno.so.hidethis (or something else) disables the presenter console. So to recap, open nautilus as root, or use a terminal and go to /usr/lib/libreoffice/program/PresenterScreen.uno.so and rename it to something else, but don't have to delete it. I hope a lot of people see this. It is much easier to multi task during a presentation when the presenter console is running, though it is very smooth and slick, but is not mature yet. I do enjoy it, but the group I work with does not, and the console removes all options for file navigation, and opening another presentation, changing volume, playing solitaire (just kidding). Thanks everyone.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.