I am trying to stop X Server so I can install some new NVidia drivers. However, the moment I type "sudo service lightdm stop", the computer goes into a blank screen, and nothing happens.

Any ideas?


MacBook Pro Retina (10,1), Xubuntu 13.04

  • lightdm AFAIK is login Window and its not the Xserver – Stefano Mtangoo May 15 '13 at 14:28
  • 2
    ... but stopping it will also kill your X-session. – aquaherd May 15 '13 at 18:09
  • I have the same problem, drivers are installed. It seems to me that my problem is in presence of gdm (I have both lightdm and gdm installed, I am using lightdm). But still not sure how to fix it. – Yuri Feb 22 '14 at 1:09

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

If you are using GNOME:

sudo /etc/init.d/lightdm stop

to start again:

sudo /etc/init.d/lightdm start

If you are using GNOME:

sudo /etc/init.d/gdm stop

to start again:

sudo /etc/init.d/gdm start

If you are using kde:

sudo /etc/init.d/kdm stop

to start again:

sudo /etc/init.d/kdm start

Once you stop X, you need to get to virtual terminal. In Ubuntu its Ctrl+Alt+F1 - F7, to login, and gain access to the system.

| improve this answer | |
  • Non of these commands work :( It just returns command not found. – mbilyanov May 15 '13 at 14:46
  • Which display manager are you using? – Mitch May 15 '13 at 14:48
  • 1
    Thanks: "sudo /etc/init.d/lightdm stop" kills X Server but I am immediately left with a blank screen, not terminal, just I like I am dropped into a blank screen when I hit CTRL+ALT+F1. Something is fundamentally broken. :( – mbilyanov May 15 '13 at 14:49
  • X Server? It is Xubuntu 13.04. – mbilyanov May 15 '13 at 14:57

Here is another not so elegant solution that worked for me, I had same problem (still don't know why..): Just start up an ssh server before you kill the X server and do the driver install remotely from another machine.

| improve this answer | |

Try pushing Ctrl+Alt+F1 (or whatever the Mac has) and login to install your drivers

| improve this answer | |
  • Thanks, this is another strange part. All my virtual terminals are a blank screen, black, nothing. Then when I go CTRL+ALT+F7, the X Windows comes back. I do not understand. – mbilyanov May 15 '13 at 14:31
  • You can also try to reboot into Recovery Mode and access the terminal If you have the option – BeryJu May 15 '13 at 14:33
  • So? Any driver updates etc. I make under Recovery Mode's terminal will have effect on the actual SYS, right? – mbilyanov May 15 '13 at 14:47
  • yes, as long as you boot using the Recovery Mode from the SYS – BeryJu May 15 '13 at 15:00

What others already said Get into tty 1 - 6 first and then sudo service lightdm stop.

My workaround:

Boot into console mode from the beginning. To do that, edit /etc/default/grub file. Make sure you connnect automatically to your home network, you are on wired network, or at least you know how to use nmcli to connect to a network.

Change line 12 from "" to "text" as shown bellow. Save, sudo update-grub, reboot. Once you are presented with console login screen, go ahead and log in, do the installation, edit /etc/default/grub file back the way it was, sudo update-grub and reboot.

enter image description here

BONUS : Get yourself elinks console browser before you edit the grub file, so that in case you funk something up, you can google stuff from the command line.

Other things you could: sudo pkill X

| improve this answer | |

I had the same issue and got it to work with a different workaround.

I had to first reduce the resolution inside X to something low (800x600). Then when I went to tty and stopped lightdm, I didn't get a blank screen.

| improve this answer | |

You could install the driver from "Software Sources" in the last tab, if you want a beta driver add the xorg edgers ppa

enter image description here

If you have any hardware that need a nvidia/amd/ati/wifi driver is will show you a option there.

You could boot recovery mode and drop to a root console and install the driver that way, but you will have to reinstall it after every kernel upgrade.

| improve this answer | |
  • nVidida Drivers need to be installed with no running XServer I think, also it's mostly better to download drivers from nvidia.com because they are newer. – BeryJu May 15 '13 at 15:11
  • if you add the PPA i linked you can get the latest, only lag a day or 2 behind, stable drivers are in the xswat ppa – GM-Script-Writer-62850 May 15 '13 at 15:30
  • Hi, thanks for the help. I messed up my Linux badly by installing an Nvidia driver that was not compatible with my Kernel. Then I got a Kernel-Driver mismatch and could not really recover. Just re-installed Xubuntu 13.04 and started from scratch. This is tricky and I do not understand how to do this right. – mbilyanov May 15 '13 at 17:19
  • I assume you want the 319 driver, it will slow up in the xswat ppa soon, atm there is no raring repo there, you can get the beta driver from the xorg edgers ppa (BETA TESTING) if you cant wait sudo apt-add-repository ppa:xorg-edgers/ppa;sudo apt-get update;sudo apt-get dist-upgrade you may need to go into software sources to get the 319 driver – GM-Script-Writer-62850 May 15 '13 at 22:56
  • Hi, I will start a new question related to this. Could you please help me in understand how to find the right driver? The question will be: askubuntu.com/questions/296168/… Thanks. – mbilyanov May 16 '13 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.