I installed Ubuntu 13.04 on a secondary hard drive, which has succeeded. But there is no GRUB entry for Windows 7 as an option. Boot-Repair and update-grub did not appear to help. http://paste.ubuntu.com/5667558/

I should note that I didn't realize my PC has UEFI, which I've since disabled.

I want GRUB on sdb.

  • The boot-repair seems to see some FAKE-RAID NTFS partitions. something like '/mapper/pdc_XXXXXXX`. I have no idea how to fix it though. – user68186 May 15 '13 at 15:12
  • @user68186 Turns out this was the problem. See my answer below. – JustV May 17 '13 at 21:10

After much reading, I figured out the problem. Turns out it had nothing to do with UEFI.

My Windows 7 drive had some RAID 0 metadata on it. My PC does NOT have a RAID array, but my OEM set it up this way for some reason. Apparently this metadata interferes with GRUB2's ability to search the drive. Therefore you have to remove the metadata.

If your PC does have a RAID array, this may not work and you may lose your data. Either backup your data or ask someone who knows more about RAIDs.

First, I backed up the metadata, so I could replace it if Windows didn't boot afterwards:

dmraid -D -r

dmraid(8) explains this more.

Then I did the following commands:

dmraid -an
dmraid -si
dmraid -E -r

GRUB was able to see Windows after this.


What about updating the Grub using command

sudo update-grub

UPDATE I tested in my Installation and it Worked. If it does not for you (as per your comment) I would suspect that your Windows boot partition got a problem. I suggest you repair your window using CD (Note that just a startup repair is enough if it fails then go to commandline from the same cd and type bootrec /fixmbr ) Then using your Ubuntu CD repair you Grub and Win7 should be there

  • There's still no Windows 7 entry. The command output was this: Generating grub.cfg ... Found linux image: /boot/vmlinuz-3.8.0-19-generic Found initrd image: /boot/initrd.img-3.8.0-19-generic Found memtest86+ image: /boot/memtest86+.bin done – JustV May 15 '13 at 14:49
  • Then it seems you windows boot partition have got problem – Stefano Mtangoo May 15 '13 at 14:52
  • strange! I just did it in my terminal and I can see Windows 7. What was the last thing you did to your installation? – Stefano Mtangoo May 15 '13 at 14:55
  • Let me remember: I installed Ubuntu on my second drive. UEFI was enabled, but after install I disabled it and ran Boot-Repair with default settings. Later I tried sudo update-grub. I can't think of anything else. Do I need to mount Windows' drives before I run update-grub? Could that be why it doesn't see it? – JustV May 15 '13 at 15:00
  • I just tried mounting them and it didn't help. – JustV May 15 '13 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.