EDIT: Updating to Ubuntu 13.10 solved this issue for me out of the box.

I'm trying to get some control over the brightness of my Samsung QX411 (Integrated Intel and discrete Nvidia, though Ubuntu doesn't see the latter yet, I'll play around with Bumblebee later)

Using the FN+up/down lowers the screen brightness from max to one peg down or back up. If I try to bring the brightness down any more, it just flickers and stays the same.

I can lower the brightness in Settings, but that's delicate and gets reverted to max if I open up the brightness settings again, or log out.

The closest I got was adding acpi_backlight=vendor to a line in /etc/default/grub, (source) I could consequently lower the brightness a couple of pegs down to the minimum with FN+down, but then it's as if the problem got inversed, and I'd get stuck in the bottom tier, I could only increase the brightness by one peg and back down. Rebooting would revert to max brightness.

acpi_osi=, acpi_osi=Linux, acpi_osi=vendor, acpi_osi='!Windows 2012', acpi_backlight=Linux, acpi_backlight='!Windows 2012' don't do anything for me.

I've also tried adding echo 2000 > /sys/class/backlight/intel_backlight/brightness to /etc/rc.local, where my max value from cat /sys/class/backlight/intel_backlight/brightness is 4648, which didn't do anything. (same result with echo 2000 > /sys/class/backlight/acpi_video0/brightness) source

Samsung tools also didn't help in this regard.

I've spent hours on this, it's getting quite frustrating. Any help would be greatly appreciated.


Just add acpi_osi= not acpi_osi=Linux that's how i got it to work for me.

|improve this answer|||||
  • Unfortunately no change – Adam May 15 '13 at 10:55
  • Damn. Sorry, good luck though. – Lemagex May 15 '13 at 13:57

If your nvidia is on as it appears to be, you need to install proprietary drivers and bumblebee to switch it off during boot, after reboot brightness works fine with the intel card which is in action.

|improve this answer|||||

I have same issue whit my Lenovo v570 laptop. My solution is writing a basic shell script;

echo $1 >> /sys/class/backlight/intel_backlight/brightness<

And copy it wiht # ln [script-name-here] /usr/bin

And execute it with # kbrightness 500 (I choosed 'kbrightness' for script name)

Solution isn't for FN keys but I use this method.

|improve this answer|||||

Updating to Ubuntu 13.10 solved this issue for me out of the box. It doesn't seem to be the updated kernel that fixed it, as the issue still exists on my Arch install with the latest kernel installed.

|improve this answer|||||

I wrote a sample script using bash dialog, in order to change my laptop brightness until they fix that in 13.10.

Here is the link to the source on github: https://github.com/kjpopov/Ubuntu-Useful-Scripts/blob/master/choose_brightness

You can edit it to add more values, and also you can change line 33 to make it work for your video adapter.

I am using an Asus X55U laptop with a Radeon HD 6290

Ensure you execute the script with root privileges.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.