I have installed Nemo from the Cinnamon PPA and used the instructions here to set it as the default file manager on my system (Ubuntu Raring). It works perfectly, but causes a strange issue with the system wallpaper.

When I log in, no wallpaper is loaded and the background is simply the remnants of LightDM with the login box etc visible. Only when I open Nemo, close it, and open it one more time does the wallpaper load. I assume this means that Nemo has taken over responsibility for the desktop from Nautilus, but I would like to know how to have it load the wallpaper immediately. Thanks for any help.

  • This sounds more like a bug. Have you checked to see if this is a known issue?
    – RolandiXor
    May 14, 2013 at 15:33
  • Exactly the same happening here as well. It is really a bug...
    – Zoltan
    Jun 3, 2013 at 0:41

2 Answers 2


For me these steps solved this problem. Source: http://www.webupd8.org/2012/12/how-to-install-nemo-file-manager-in.html

  1. Add nemo to Startup Applications, just run the following command:

    sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/nemo-autostart.desktop

  2. Launch Startup Applications and uncheck Nemo

  3. Log out and log back.

  • This did not solve the problem for me. But it was worth a try. Oct 26, 2013 at 5:21
  • This just probably just stops it autostarting - it doesn't stop it managing the desktop,,,
    – Wilf
    Jun 22, 2015 at 23:50

For me the solution was to download a package called compton which is a lightweight window manager. I put it in my session startup. I got it from this PPA: https://launchpad.net/~richardgv/+archive/compton

I got the idea from this thread about the nemo wallpaper issue which suggests a lot of things but compton is what finally worked for me: https://bbs.archlinux.org/viewtopic.php?pid=1328476 I also installed nitrogen which is a desktop backgrounds settings tool that is lightweight. I'm not sure if it is required and it didn't work by itself for me. But I need it to change the background as the default gnome one I have doesn't work when I run nemo. Note that nitrogen doesn't seem to have any automatically created menu item or icon, I had to launch it from a terminal.

I am using a system which use to be ubuntu lucid with gnome and fancy compiz effects. Then I upgraded to precise with Unity and since I hated that I've slowly been trying to fix the things that bug me. So, my system is a total mish-mash and YMMV. However, I do think both nitrogen and compton are lightweight and standalone so hopefully they would work on other setups. And, it didn't require any real hacks :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.