I am experiencing problem with versions from 10 to 13 of Ubuntu on Dell Latitude E5420, specifically. The behavior is very weird. If Ubuntu is started without power supply plugged in, the notebook works as a charm. At the moment the charger is plugged in, the notebook starts working slowly, the mouse pointer is moving like an ant. Unplugging the charger turns Ubuntu back to its normal condition. Plugging it in, back, repeats the issue. If Ubuntu starts with power supply plugged in and 100% charged battery it is OK, however if not with fully charged battery and on power supply, the issue occurs again. So far, I believe this happens only on that model of Dell. On Latitude E5410 I did not manage reproducing it. Has anyone of you had such a case?

  • Are you also running Windows on the same laptop? What happens if you do the same things you described above when you are running Windows? – karel May 14 '13 at 10:55
  • Yes, I do run Windows on the same disk. Windows works fine. By the way, that happens either from the HDD or booting from a USB stick. Thanks a lot for your answer. – Alexander Tachev May 14 '13 at 12:38
  • I found this link to somebody who had a similar problem, and tells how he solved it. Please pay particular attention to the part about installing the Jupiter power management application. There are a lot of reports on the web from people who say that Jupiter works better than other power management applications such as laptop-mode-tools. – karel May 14 '13 at 12:56
  • Looks like a very much possible solution of my problem. Shall try and come back. Thank you very much. – Alexander Tachev May 14 '13 at 14:34

I had this problem on UBUNTU 13.04 on the same laptop (Dell latitude 5430)

I did a simple thing - just a lucky shot - .. updated all the xserver packages that I had as follows:

sudo apt-get install xserver

it will correct you and show about 3 xserver packages .... install them all (they should be installed .. but whatever)

sudo apt-get install <xserver-****>

then upgrade them

sudo apt-get upgrade <xserver-****>

and it is solved now ^_^


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.