1

First and first, I had Netbeans installed on my laptop when it was on 12.04 but after I upgraded it to 13.04 and could not find it on my dash so thought it was removed on upgrade.

I tried to reinstall it using the .sh file from they're official website and then I found out that it was already installed so I uninstalled it from my laptop and tried to again to install it(so it would be a fresh install),but when the installer came out it told me that "All components are installed".

After that I tried cleaning my system with ubuntu tweak's janitor and tried again but yet the problem persisted, and after this I manual deleted any directories/files related to netbeans(searched the directories/files with nautilus) and yet the problem is still there.

When the installer start(without errors), it simply says:"All components are installed" and the "Next" button is deactivated.

I installed Netbeans 7.0.1 from software center but I would want to install the latest version.

Any clues/tips/help?

1
  • sudo apt-get --purge remove netbeans[fullVersionOrSomething] and then install from your downloaded latest version.
    – nickanor
    May 14, 2013 at 10:40

2 Answers 2

1
  • Download Netbeans from https://netbeans.org/downloads/
  • Make sure you have Java version installed: Type this command in a Terminal:

    java -version You should get should get an output similar to this:

java version "1.7.0_21" Java(TM) SE Runtime Environment (build 1.7.0_21-b11) Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)

  • Next install Netbeans: chmod +x netbeans-7.3-javase-linux.sh;
  • Launch installer ./netbeans-7.3-javase-linux.sh
  • If you want to install it in /opt launch it with sudo: sudo ./netbeans-7.3-javase-linux.sh

See also the instructions: Installing the Software

2
  • I don`t understand you! Do you want to install it system wide and for all user or simply for yourself? If so than use the sh file without sudo.
    – koni_raid
    May 16, 2013 at 7:10
  • System wide,but nevermind I will just install it again on the other user.Thank You.
    – adi
    May 16, 2013 at 16:42
0

This is what worked for me: remove the ~./nbi directory.

1) open terminal

2) rm -r ~/.nbi

Hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .