I am dual-booting MacBook Air 5.2 and Ubuntu 13.04 using rEFInd, so far things appears to work except when Macbook Air goes from sleep mode into standby mode (dump system state from RAM to SSD), it will not recover when I open the lid or click on touchpad.

Specifically, I can see keyboard light on but no output on screen at all, so it's impossible for me to tell if it has booted into the login screen or not. The only solution appear to force shutdown MBA at this point by holding power button

some info on MBA standby mode

  • I have this problem as well, Linux mint 15 instead of Ubuntu, and havent really tinkered with it tho, so doubt that has anything to do with it. – Karthik T Oct 27 '13 at 5:32
  • For me this appears to happen only when on battery power, not AC. – Karthik T Oct 27 '13 at 5:34

I'm rEFInd's developer. I've heard another report similar to this, but I'm unable to replicate it myself, since my one Intel-based Mac is an elderly 32-bit model that doesn't exhibit this behavior. Since the problem doesn't manifest within rEFInd itself, I can't simply create a debugging version to give to somebody like you who does have the problem; it's going to take hands-on fiddling with the hardware to identify the cause of the problem and find a solution. The solution could be something like an alternative installation method for rEFInd or a code change to rEFInd, but whatever it is, I'm afraid that I can't find it unless/until I get a computer that has the problem. I have no plans to buy any new Macs in the near future, so this will have to wait indefinitely or for somebody else to find a solution.

  • in that case I think grub2 is probably the next best thing, thanks for the confirmation. – bitinn May 14 '13 at 16:14
  • FYI, I installed Ubuntu 13.04 on my Macbook Pro 5,3 (2009), not a dual-boot, just Linux, so GRUB2 is used as the bootloader. I have one big problem with the ACPI management. I'm forced to boot with APCI=off or else the machine freezes after few minutes using it. I found that the parameter ACPI_OSI=Linux (in the GRUB config file) makes it work for 20-30 mn before a general freeze. The parameter MAXCPUS=1 makes it work more or less ok, but the Macbook is less powerfull with only one CPU. – greguti Jul 14 '13 at 20:52
  • I tested the 3.9.x kernel and the 3.10.x kernel, same trouble. I tested nVidia drivers 310 (tested, recomanded) and 313-updates, same trouble. I tested the Nouveau driver, terribly sluggish... So I guess the trouble is to be found somewhere between the Macbook "faux BIOS" (?) and the power management of the distro. – greguti Jul 14 '13 at 20:56
  • Hi Rod, this happens for me as well. One thing Ive noticed is that it happens only with Battery mode, not AC, not sure if that helps – Karthik T Oct 27 '13 at 5:34
  • Rod, I can confirm this behaviour as well. If you want to try some "live" debugging contact me. – tomodachi May 5 '14 at 18:57

I tried the old rEFIt (instead of the forked project rEFInd), it works beautifully with Macbook Air 5.2 and Ubuntu 13.04, and the wake from sleep problem is gone.

So I highly recommend people having this problem give rEFIt a try.

  • 1
    I have the same problem on my retina Macbook Pro (10.1), I will try using rEFIt. Just curious, how did you go from refind to refit? Did you have to reinstall Ubuntu afterwards? – mna May 18 '13 at 21:30
  • If rEFIt works and rEFInd fails, and if you're willing to help with rEFInd development, then trying various versions of rEFInd to isolate when it stopped working would be immensely helpful. You can download any version here. If you can tell me that the problem began with version X, then I can compare that version to the previous one and maybe identify what causes it. Please report the findings to me directly (rodsmith@rodsbooks.com). – Rod Smith Oct 27 '13 at 16:25
  • @RodSmith any update on a fix in reFind? , If not perhaps I can provide some testing ground. – tomodachi May 21 '14 at 20:00
  • There's a lengthy discussion of the issue here. In brief, several people report that installing rEFInd to a dedicated HFS+ partition using install.sh --ownhfs {device_file} fixes the problem. Some people report having to jump through some extra hoops, though, so there may be some model-to-model differences. – Rod Smith May 22 '14 at 0:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.