Yesterday I installed installed ubuntu 12.04 on my Acer aspire one D270-1838. Everything worked ok, except I couldn't adjust brightness, I fixed it changing:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

in grub.

The problem is when I closed the lid it suspended properly but trying to start it again it showed a crashed screen. I have read people with a similar problem but they report screen completely black, mine isn't. I wanted to upload an image of the screen but I don't have the reputation....

Something I can do to suspend my netboot and that works fine is type:

sudo pm-suspend --quirk-dpms-on

and it suspends correctly but without authentication, that's not a problem for me but it is tedious. Also, I can enter a virtual terminal with ALT+CTRL+F1 which works fine and kill X, this fixes the screen crash but also terminates my session. however there are sometimes that after the first try if I try to close the lid and open it up again, the screen stays on but black and I cant enter the virtual terminal.

I'm not tech saavy, but I hope you can direct me to a way of fixing this problem.


Permanent activation of "--quirk-dpms-on"

$ sudo pm-suspend --quirk-dpms-on

This solves the problem for me too (thank you for the information).

To permanently activate the solution you have to set it up in /etc/pm/config.d/defaults.

I copied the default config file /usr/lib/pm-utils/defaults by typing:

$ sudo cp /usr/lib/pm-utils/defaults /etc/pm/config.d

After that I added the following line at the corresponding place in the file.


For details see the comments in the file or the manual page of pm-suspend.

have fun ;-)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.