Today I downloaded and installed OpenOffice through the PPA repositories, using apt-get (hope that's what I mean to say), and when the program checked for updates it said there was a new version - 3.4.1 which I need to download from the website.

I am reluctant to download from the website, because I tried this earlier (before using the PPAs) and while I was able to download the .tar.gz file and extract the DEBS, I couldn't figure out how to install it. I found instructions on the internet that told me how to install, but for some reason, Ubuntu didn't know the application was installed! Couldn't find it in Dash, and to run I had to find the OpenOffice folder and doubleclick soffice.bin.

So my question is, how to I download and install the latest version of OpenOffice without it being messed up as above?


1 Answer 1


Ubuntu comes with an office suit by default, called Libre Office. If you would still like to install Open Office follow these directions.


Download Open Office from Openoffice.org (or use this direct link).
Save the file to your Downloads folder.


I highly recommend that you remove ALL previously installed versions of Open Office before proceeding!

Open a terminal and cd to the downloads folder:

cd Downloads  

Now we need to untar the installation folder:

tar -xvzf Apache_OpenOffice_incubating_3.4.1_Linux_x86-64_install-deb_en-GB.tar.gz

Then cd to the folder we just extracted:

cd en-GB/DEBS  

And install all the packages:

sudo dpkg -i *.deb  

When that has finished cd to the "Desktop Integration" folder:

cd desktop-integration  

and install those packages:

sudo dpkg -i *.deb  

And you're done!

You can now remove the en-GB folder.

  • 2
    I just would like to make it clear for the author of question: it is important to install all packages at once, that's why dpkg -i *.deb can't be replaced with multiple dpkg -i %package% commands unless you guess the correct order of installation to resolve all dependencies. That's the only problem that makes it a bad idea to use graphical package installers for these DEB packages. May 13, 2013 at 17:24
  • Seth - I did what you suggested the first time I tried to install OpenOffice, but it didn't work because Ubuntu didn't know Open Office was installed. I couldn't find it in Dash, and couldn't associate it with file types, and the only way I could run it was by going into the /opt/openoffice.org3/program folder and running soffice.bin. If the method you suggest is the only way to do it then I'll have to just stick with the older version unfortunately.
    – Sam H
    May 14, 2013 at 8:01
  • @SamH Did you install the desktop integration packages? Those are what put the icons in the dash.
    – Seth
    May 14, 2013 at 13:11
  • @Seth, yes I did. Did it straight after I installed everything else. Maybe I'm missing something?
    – Sam H
    May 14, 2013 at 14:21
  • Ok, it's working! I used apt-get --purge OpenOfficeorg to remove the software, then I downloaded the package and used the dpkg -i command to install all the debs. Then I installed the desktop-integration debs, and it is all working now! In short I have no idea what I did wrong last time, but it is working! Thanks everyone for your help!
    – Sam H
    May 14, 2013 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.