30

When I turn off " record activity" in the privacy settings, my activities are still recorded in the "recent files" folder (even when I am using a truecrypt volume).

I haven't figured out a PERMANENT solution to this problem. It sucks to delete history via terminal manually and what happens if I forget?

3
  • 1
    One of you should post that as an answer, but beware that does not clear everything (such as bash history and specific applications may also track recent files). – Panther May 13 '13 at 17:05
  • Exactly how are you deleting the history via the terminal? I'd really like a temporary solution. – Hubro Jul 9 '13 at 15:34
  • in Ubuntu 13.04 the settings.ini file is in /etc/gtk-3.0/settings.ini and the configuration will be applied for all users – user198454 Oct 3 '13 at 16:47
40

The method with editing ~/.config/gtk-3.0/settings.ini doesn't work with Nautilus 3.8. But there is better and simpler way. Simply open dconf-editor, navigate to org->gnome->desktop->privacy and uncheck the remember-recent-files key. That takes care of it, once for all!

3
  • 2
    org->gnome->desktop doesn't have privacy for me in 13.04. – Prinzhorn Jan 4 '14 at 11:35
  • +1 neat. For noobs like me, dconf-editor just runs in my terminal - it's a UI :) – Ben Jan 18 '14 at 23:07
  • 3
    in Gnome 3.8 Settings -> Privacy -> Turn of Usage & History – Din Jun 29 '14 at 11:17
8

Disable the Nautilus Recent Files list

To permanently disable any recent files from showing up in the Nautilus Recent sidebar item, open the ~/.config/gtk-3.0/settings.ini file with a text editor:

gedit ~/.config/gtk-3.0/settings.ini

and under "[Settings]", add the following lines:

gtk-recent-files-max-age=0
gtk-recent-files-limit=0

If this file does not exist, create it. Make sure the header says "[Settings]" and not "Settings". This is how the file should look after editing it:

[Settings]
gtk-recent-files-max-age=0
gtk-recent-files-limit=0

(there can be other items below these, of course).

To apply the changes, log out and log back in.

Copied from Webupd8 exercising (cc) BY-NC-SA WebUpd8 : Nautilus 3.6: How To Clear The Recent Files List (Or Disable It)

1
  • 2
    Doesn't work for me on 13.04. – pcworld Aug 20 '13 at 23:27
6

In 14.04 go to Settings > Security & Privacy > Files & Applications and check "off" Record file and application usage.

2
  • not work! i excluded all the videos, my movies folder, my video player applications.. but it keep adding videos into "Recent" list – Hiep Apr 24 '17 at 21:17
  • It worked at the time for me in 14; I've been using 16 for awhile now and couldn't say if its still valid or not. – Paul Gregoire Apr 25 '17 at 3:06
3

If you're using Ubuntu 17.10 and above (or Ubuntu GNOME) then:

  • Open Settings
  • Open the Privacy Tab enter image description here

  • Click Usage & History and disable the "Recently Used" label enter image description here

3

Using the terminal:

gsettings set org.gnome.desktop.privacy remember-recent-files false
2

You have 4 options (AFIK)

  1. Use the guest account. The guest account is confined by apparmor and the session is wiped when you log out.

  2. Each user should have a separate account.

  3. Write a script to clear your private data.

  4. use bleachbit.

1
  • I suppose you could always boot from a flash drive as well. – Panther May 13 '13 at 16:48
1

As the settings.ini method didn't work for me on Ubuntu 13.04, here is a workaround that should be pretty reliable:

$ rm ~/.local/share/recently-used.xbel # clear current file history
$ touch ~/.local/share/recently-used.xbel # create a 0-byte history file
$ sudo chattr +i ~/.local/share/recently-used.xbel # make it readonly
1

Starting with GTK 3.8 (Ubuntu 13.10 and later) you can just use the following setting in
~/.config/gtk-3.0/settings.ini to disable the "Recent files" feature completely:

[Settings]
gtk-recent-files-enabled = 0
1
  • 1
    didn't work for me on 13.10, dconf-editor solution works well – baptx Dec 9 '13 at 12:44
0

Simply open dconf-editor, navigate to org->gnome->(filemanager e.g. nemo for me)->privacy and uncheck the remember-recent-files key. That takes care of it, once for all!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.