I recently bought a Nokia 620. Ubuntu 13.04 does recongize it and is able to mount it. Music files transferred through the file explorer don't show up at all in my phones media player. Trying to do it with Rhythmbox makes it crash. I have found that Clementine is able to do the job. However, transferred tracks lose their "artist" tag for some reason.

So here comes the question: What program you use to transfer music on you WP device? Or do you do it through Windows?

7 Answers 7


WP devices use the MTP protocol. Have you tried using Nautilus with the GVFS MTP plugin?

There is a step-by-step guide on how to install and setup an up-to-date GVFS MTP plugin using a PPA in Ubuntu 12.04 and later at http://www.webupd8.org/2013/01/upgrade-to-gvfs-with-mtp-support-in.html.

  • 3
    I tried both gvfs-mtp and Go-Mtpfs. While both allowed me to navigate in my phone, none of them nor the default Ubuntu configuration allowed the file I dropped in my phone's music folder to be identified by it's player.
    – user107320
    May 13, 2013 at 18:58
  • Nautilus already shows the device most times, no extra software required (make sure the lockscreen is unlocked)
    – NoBugs
    Nov 22, 2014 at 5:10
  • It would be better to include the essential part of the linked resource in the answer in case the resource becomes unavailable. Feb 19, 2016 at 11:49

You may wirelessly transfer/copy music files to your Windows Phone via a web browser using the updated version of Music Drop by Codeceptive Studios. The first version was great but the new one is even better! And what's best about this app: it's fast, efficient and most of all free ;-)

  • I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Feb 19, 2016 at 11:48

I have Nokia Lumia 920. I need some time but i found a relative fast way to bring the music to my phone it should work with every Windows phone.

The problem i had: I was able to move Songs in to the folder Music on my phone but the phone don't recognized them.

You have to install the mtp protocol on you're Ubuntu Computer/Laptop And you have to have a file-manager on your windows-phone(There is an official App from Microsoft,download it in the store)

How i solved it : First thing you connect your phone/mobile via USB with your Computer. There it should appear like an USB-device. Than you move all your music in to folder Downloads on the phone.

The next Step was done on my mobile/phone. You move the songs from Download to music and then they appear in the music list.


My phone gets successfully mounted when i check the Nautilus using MTP. Then I can browse my phone and sd card memory.

Also, I have transferred videos and songs to my Lumia 720, which do appear in the list but takes sometime to reflect in the music+videos app in phone. A very limited video codecs are supported like mp4, avi etc.

Alternative could be to remove the sd card and then transfer.

  • You can transfer to sd card easily just plugging it in and moving with Nautilus, but at what point does it read from the card?? On restart? Days later?
    – NoBugs
    Nov 22, 2014 at 5:16
  • 1
    Apparently the music player doesn't show anything you add, but "Audio Book Player" app helps
    – NoBugs
    Mar 21, 2015 at 15:34

I have a Nokia Lumia 710 with WP7.8. My laptop has Ubuntu 14.04. It recognized my phone, I could even see it with different mtp tools like: gMTP, mtp-detect, file browser I even recompiled the libmtp... However I could not list the files and could not copy them.

Finally I disabled the password on the phone and reconnect it, then every tool could browse it.

(Don't need to boot my windows laptop to sync with Zune anymore... \o/)

  • 1
    With WP8, 8.1 it usually works whenever it is unlocked.
    – NoBugs
    Nov 22, 2014 at 5:17

seems Nautilus (in 18.10 anyway) picks up the phone and the SD storage. One can copy the music files over into teh music folder, but the xbox music app seems reluctant to identify all the tracks. I found going into settings and removing the SD card (Settings-> storage sense -> SD Card ->[scroll down] Remove SD Card), and then restarting the phone makes the music appear.


Try disabling password on Windows phone. It has worked for me. You can enable your password again once you're done transferring the files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .