I used my 12.10 as my NFS server. And the 13.04 as the client. After installing NFS to both of my laptops I added this in /etc/exports

  1. /export client.ip.add.ress/24(rw,fsid=0,insecure,no_subtree_check,async)
  2. /export/users client.ip.add.ress/24(rw,nohide,insecure,no_subtree_check,async)

then I tried to run on my 13.04 this

$ sudo mount servername:/export/users /mnt

then I got the error mount.nfs: Failed to resolve server servername: System error

I tried to follow the instructions in this site.


You don't make clear in your question as to how you have set up name resolution in your network for your server. Do you have a DNS server configured with the name of the server in it or have you added the server-name to the hosts file on your client.

A couple of ways you could progress here:

Check in file /etc/hosts for an entry of the form: server_ipaddress servername



$ sudo mount server_ip_address:/export/users /mnt



$ sudo mount servername.local:/export/users /mnt

I think 13.04 deploys avahi by default which provides a service called multicast dns using this allows all hosts to be identifed as hostname.local



| improve this answer | |
  • Thanks! It works! Haha. I don't have the DNS server configured so I just replaced the servername by its ip address. Thanks again! – user158335 May 13 '13 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.