9

I have a Lenovo Y500 with Windows 8. I successfully got Ubuntu 12.04 installed alongside Windows 8 and the nvidia drivers just worked from the start. The sound wasn't working at all however, and although alsamixer was alive and well when I started out, I seemed to have completely destroyed it now.

I keep getting:

$ alsamixer
cannot open mixer: No such file or directory

Kernel version:

$ uname -a
Linux laptop 3.5.0-28-generic #48~precise1-Ubuntu SMP Wed Apr 24 21:42:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I've tried both of the following packages from https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages:

oem-audio-hda-daily-dkms - 0.201305101424~precise1
oem-audio-hda-daily-lts-quantal-dkms - 0.201305101424~precise1

but to no avail.

This is the output of my alsa-info:

http://www.alsa-project.org/db/?f=09851ab8c4380c25feaea7ff1de68d847bd4160c

I've tried many other solutions as well but nothing seems to get alsamixer back, nevermind trying to get the audio to work again.

PS. when alsamixer was still working I did check the levels and it was not a case of the channels being muted.

Edit

  1. /usr/bin is in $PATH.
  2. no asound rc or conf files anywhere.
  3. alsamixer is in /usr/bin, can't run it as alsamixer, /usr/bin/alsamixer not with sudo, even after purging and re-installing alsa-utils.

Edit 2

$ ls /dev/mixer -l
ls: cannot access /dev/mixer: No such file or directory
$ ls /usr/bin -l | grep alsamixer
-rwxr-xr-x 1 root   root       65344 Mar 28 23:54 alsamixer
-rwxr-xr-x 1 root   root       61272 Dec 18  2011 gnome-alsamixer

Edit 3

$ ls /dev/snd -l
ls: cannot access /dev/snd: No such file or directory
  • Try to delete asound.conf file. – Radu Rădeanu May 13 '13 at 13:58
  • @Radu I do not have a asound.conf file. – skepticscript May 13 '13 at 14:20
  • Those Unknown symbol errors indicate that you have installed drivers that do not match your kernel. – CL. May 13 '13 at 14:24
  • @Radu Wow man this is a coincidence, I joined here actually to thank you for your guide on installing Ubuntu alongside Windows 8 but didn't have enough rep to comment! So, thanks! – skepticscript May 13 '13 at 14:30
  • Edit your question with the results of ls /dev/mixer -l and ls /usr/bin -l | grep alsamixer commands. – Radu Rădeanu May 13 '13 at 15:07
5

Firts of all, you should check if you have /usr/bin directory in your $PATH in terminal with:

echo $PATH

If the $PATH is ok, check if alsamixer is there:

ls -l /usr/bin | grep alsamixer

If yes, try to run alsamixer like this:

/usr/bin/alsamixer

If still doesn't work delete .asoundrc file (in your home directory) and /etc/asound.conf (if you have them) and reinstall alsa-utils:

sudo apt-get remove --purge alsa-utils
sudo apt-get install alsa-utils
  • 1
    I updated my question with the results. After reading your guide to installing Ubuntu alongside Windows 8 I have a lot of faith in you! ;D – skepticscript May 13 '13 at 14:49
  • Updated my answer again. On my other PC with Ubuntu 12.04 installed ls /dev/mixer -l doesn't show anything either. – skepticscript May 13 '13 at 16:32
  • Marking this as the solution as it brought me to the final conclusion. – skepticscript May 14 '13 at 9:16
  • 1
    Radu, thank you very much. The simple checks and your if/else guide was spot on. The final solution (purge and install again) resolved a 3 week long issue I was struggling to resolve. So nice to see alsamixer again. Thanks. – James Feb 16 '15 at 17:03
5

I hit this error and solved it by adding myself to the audio group.

sudo addgroup <username> audio

Log out and back in, then test.

  • It might be enough to just run newgrp audio and log out && log in, at least within the same shell. – moon.musick Mar 25 '15 at 21:40
1

I had the same problem and it happened while the sound card (ALC662) was disabled in BIOS. Enabling it, allowed me to start alsamixer. I hope it helps.

  • Could you explain it a bit more and maybe add screenshots? – user45853 Mar 17 '14 at 21:11
  • This might have helped, however I just re-installed and started over. – skepticscript Mar 18 '14 at 10:00
0

For me using the -c parameter worked

alsamixer -c 1

but I'm on 16.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.