I having troubles with the upload and download speed of my PC card network adapter. The upload speed is around 3.5-4 MB/s and the download is 30MB/s with the r8169 6.017.00 driver from realtek. I have upgraded the kernel which installed the standard linux driver again (2.3LK-NAPI) and with this driver the speed both up and down is 13-14MB/s.

I'm connected to an 1Gbit network.

I have tried both copying data to my pc (running Windows 7) via samba and SFTP (using fileZilla). Furthermore by using a sparse file on the web server we have tested that it's definitely the server. As the speed on the loopback adapter with the sparse file is around 250MB/s and the speed differs per driver we think it is definitely the network card.

Also peculiar is the ping as it equals 138ms to the router/other pcs in the local network. But this might be explained by the fact of the latency of the network card (set at 64ms during startup..).

Running Ubuntu Server 12.04.2 LTS

Linux Klootzak 3.5.0-27-generic #46~precise1-Ubuntu SMP Tue Mar 26 19:33:56 UTC 2013 i686 i686 i386 GNU/Linux

r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:07:00.0: enabling device (0000 -> 0003)
r8169 0000:07:00.0: (unregistered net_device): not PCI Express
r8169 0000:07:00.0: setting latency timer to 64

try this


in your samba file, remove any other socket options you have

worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.