4

My router went down, so I have a temporary one installed right now that has no Wifi. I decided to pick up a USB Wifi dongle, and I want to use my Ubuntu server as the bridge. I have the driver installed, and was following the guide for setting up NDISWrapper on the Ubuntu Community manual. When I run ndiswrapper -l:

rt2870 : driver installed
    device (0846:9012) present

... So I assume that it is installed. I then run depmod -a and get no output (assuming it works correctly), and then modprobe ndiswrapper... But that returns FATAL: Module ndiswrapper not found.

This error seems weird to me, but I'll bite. I google the issue further, and find some people telling me to install 1.58 from the NDISWrapper website on Sourceforge. I try to run make in the extracted folder, but get this error:

Makefile:41: *** Please run 'make modules_prepare' in /usr/src/linux-headers-3.5.0-17.  Stop.

Still not working! But why did the previous ndiswrapper commands work? The output of ndiswrapper -v shows that it's (mostly) installed:

ERROR: Module ndiswrapper not found.
module version is too old!
utils version: '1.9', utils version needed by module: '0'
module details:
ERROR: Module ndiswrapper not found.

You may need to upgrade driver and/or utils to latest versions available at
http://ndiswrapper.sourceforge.net

This is getting very irritating, but I don't know where to go from here. When I run uname -r, I get 3.5.0-23-generic, if that helps any (a lot of scripts are asking for it)

1

Seems like ndiswrapper needs some preparation on the kernel headers to be able to use them. Execute the following in a terminal:

cd /usr/src/linux-headers-3.5.0-17

sudo make modules_prepare

After this, compile the ndiswrapper 1.58 module.

  • make: *** No rule to make target 'modules_prepare'. Stop. – Canadian Luke REINSTATE MONICA May 13 '13 at 5:40
  • Running make on ndiswrapper now gives the same error message? – grimpitch May 13 '13 at 5:48
  • Makefile:41: *** Please run 'make modules_prepare' in /usr/src/linux-headers-3.5.0-17. Stop. – Canadian Luke REINSTATE MONICA May 13 '13 at 5:49
  • The strange thing is, that it's asking for the 3.5.0.17 headers, however you are running 3.5.0.23. Check where /lib/modules/3.5.0.23-generic/build points to. – grimpitch May 13 '13 at 6:04
  • What command do I run to find that out? – Canadian Luke REINSTATE MONICA May 13 '13 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.