I get a blank screen after entering my login password at the ubuntu login screen. And after a short while the login screen is restored. Any further attempts result in a similar cycle as before. This is happening inside VMWare virtual machines. I had restored a partition from a clonezilla image to this (virtual) system. The source for the clonezilla image was a similar virtual system (which is in perfect condition) which only has one partition for everything. I can however login from the virtual terminals (tty) though, and also seem to have access to all my files. I also don't get any error messages when I try to login from the virtual terminals. Also restarting the lightdm service hasn't helped either. There don't seem to be any problematic lines in my .bashrc.

I am running Ubuntu 12.04.02 64-bit.

  • Did you manage to fix this? I'm having the same issue
    – fableal
    Nov 1 '14 at 12:18

I had this problem once, I resolved it by fixing my /etc/fstab file which had incorrectly set my /home drive. But as you mentioned, it's a single partition. I also once resolved it by reinstalling the ubuntu-desktop package.

This issue is fairly wide-spread throughout the Ubuntu community. There are several other users who have had this issue and the various resolutions seem to point towards some sort of issue with either the graphics card drivers, Unity, or Compiz. A point of confusion however is the difference between blank screen and black screen.

Here's a "blank" screen problem:

In this scenario, a user has a problem similar to the one you described: A blank screen when they attempt to login. This is different however due to the fact that they are using a physical computer as opposed to a virtual machine and also because they are not returned to the login prompt after a short delay.


The problem was resolved when the user reinstalled Ubuntu without checking the "Install third-party proprietary software" box at install, preventing the Nvidia drivers from being installed.

Here's another blank screen error. This one is a bit more similar to your problem since it's a virtual machine.

The problem that the asker had was that after installing 12.10, when they attempted to login it would go straight to a blank screen:

Ubuntu 12.10 desktop/interface not showing on VirtualBox VM after login screen

It was apparently resolved by using Gnome Classic.

What I actually suggest you do first is that you install or update the VMware Tools.


This site provides instructions on how to install VMware tools on an Ubuntu virtual machine.

If that doesn't work, I would suggest is that you try reinstalling Compiz.

How can I remove and re-install Unity?

This worked for me, so I hope it will work for you as well. I've heard this can be caused by a great number of issues, so I sincerely wish you the best of luck.

  • Could you at least point me to the posts or forums where these issues are discussed. I did try searching on google but my skills failed me. It would be even better if you could add it to your answer though. Thanks
    – Richard
    May 12 '13 at 10:13
  • Added some more detail to the answer, hope that helps you out. May 12 '13 at 12:17
  • Thanks @Alastair. I will surely check them out, and if any of them solve my issues I will mark the question as solved.
    – Richard
    May 12 '13 at 15:37

I just now had the same problem when I created a new VM with Ubuntu 12.04.5 (VMware), but I knew it was nothing hardware related because I had another VM with Ubuntu 12.04.5 (installed from Ubuntu 12.04.4 to 12.04.5), which worked perfectly fine. So by trying random things, this worked:


  • Start Ubuntu until log-in screen.
  • Before log-in, click on the Ubuntu logo button on the right side of your name.
  • Select Ubuntu 2D
  • Log in and successfully don't see a black screen


If you, after fix, again click on the Ubuntu logo before log-in and select Ubuntu (instead of Ubuntu 2D), the black screen is back.


This one worked for me (Source):

Open a text console by pressing Ctrl+Alt+F1 and then log in into text mode and enter these commands:

sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade -y
sudo reboot

As explained in the original source, this problem happens because of an update which installed incorrectly and broke the graphical desktop environment. The sudo dpkg --configure -a configures all unpacked but unconfigured packages.


I have had the same problem when I installed Ubuntu 12.04 on VMWare with Windows7 host. The login screen appeared and the after entering the password, nothing appeared on the screen. After a little search I found that "Virtualizartion Technology" is disabled under my BIOS. If you have bought your notebook with pre-installed windows, you are likely having the same problem.

You can enable the Virtualization Technology from the BIOS set up menu at the start up. Once enabled Ubuntu will work fine.

TO enable: Restart your system, press ESCAPE key to enter the start up menu. Press F10 to enter BIOS set up menu. In the system configuration, you will find the Virtualization technology disabled by default. Enable it, save and exit and you are done.

May be this will help.

Source: Blank screen after entering password on Login.


right click on your virtue machine -> setting-> hardware -> display and deselect the option "3D acceleration",it's all thing ,sorry for my bad english

  • I don't have enough points to comment, but deselecting 3D acceleration in the display adapter properties in VMware workstation got me working again. I had Ubuntu Mate 16 running in VMware Workstation on a Windows 10 host, and now I can logon again.
    – jerblack
    Jun 20 '16 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.