4

Hi I am trying to install MATLAB in my Ubuntu 32-bit 13.04 by mounting the ISO. Here are the steps i followed:

sudo mkdir /media/matlab/
sudo mount /home/"username"/Desktop/Matlab_Unix_2012a/ml2012au.iso /media/matlab/ -t iso9660 -o loop 


sudo mkdir /usr/local/matlab/
sudo /media/matlab/install

After all theese commands i get the following message:

Preparing installation files ...
Installing ...
Finished

It is supposed to open a window with the "Matlab installation" but it does nothing. EXTRA: i read somewhere that if i put -v after the install command it would show me more information about it so here it is:

    Preparing installation files ...
->  DVD                 = /media/matlab
->  ARCH                = glnx86
->  DISPLAY             = :0.0
->  TESTONLY            = 0
->  JRE_LOC             = /tmp/mathworks_2980/sys/java/jre/glnx86/jre
->  LD_LIBRARY_PATH     = /tmp/mathworks_2980/bin/glnx86

Command to run:
/tmp/mathworks_2980/sys/java/jre/glnx86/jre/bin/java  -splash:"/media/matlab/java/splash.png" -Djava.ext.dirs=/tmp/mathworks_2980/sys/java/jre/glnx86/jre/lib/ext:/tmp/mathworks_2980/java/jar:/tmp/mathworks_2980/java/jarext:/tmp/mathworks_2980/java/jarext/axis2/:/tmp/mathworks_2980/java/jarext/guice/:/tmp/mathworks_2980/java/jarext/webservices/ com/mathworks/professionalinstaller/Launcher -root "/media/matlab" -tmpdir "/tmp/mathworks_2980" 

Installing ...
Finished

Does anyone know why the installation window isn't showing up?

  • The ISO was corrupt – Axter May 15 '13 at 10:28
  • I had this problem on a fresh 16.04 installation. I made sure all updates were downloaded and did a reboot. That seemed to fix it. – Jan M. Sep 5 '16 at 14:39
6

I just found myself in the same situation with the same problem trying to install MATLAB r2014a in a clean ubuntu 14.04, the solution I found it in a post that said that was problem with the java jre

This worked for me:

./install -javadir /usr/lib/jvm/java-7-openjdk/jre/

I know you solved with a other iso, but I think someone else can find themselves with the same problem I could be interesting for them.

| improve this answer | |
  • Oh my god, you saved my day sir! Thanks so very much! – Sibbs Gambling Jun 20 '16 at 3:34
  • ./install -javadir /usr/lib/jvm/java-7-openjdk-amd64/jre/ worked for me – Laschet Jain Feb 24 '17 at 21:29
2

If you dont have X11 installed

apt-get install -y -q libxtst6 libxrender1 libxi6
| improve this answer | |
  • This is a potential answer to the issue (also posted here), though, it could have been worded more clearly. – RTbecard Oct 20 '16 at 20:35
0

The key is to find the java/jre directory. You can cd to /usr/lib/jvm/ and list all files. There you may find java versions like java-8-openjdk java-8-openjdk-amd64 java-1.8.3-openjdk-amd64 java-x-oracle You can one as your Java engine.

Personally, I picked the following one and the this command for my MATLAB R2016a installation on Bbuntu 16.04: sudo sh ./install -javadir /usr/lib/jvm/java-8-openjdk-amd64/jre/

You can try different jdk/jre for your case, if you want. Hopefully this works for you.

| improve this answer | |
0

After running

chmod -R u+x MATLAB_INSTALLER

i also installed the JRE for Ubuntu 18.04 using

apt-fast install default-jre

the graphical installer for MATLAB managed to start on running

MATLAB_INSTALLER/install
| improve this answer | |
-1

Matlab is installed, it didn't show a window because you didn't add a "-v" extension to it. Somewhat like this

sudo /media/matlab/install -v
| improve this answer | |
  • Read the question, the OP already did this. – edwin Aug 3 '13 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.