When I start my computer, windows 7 boots up as it would usually do before I installed ubuntu. So, it is not giving me an option to boot ubuntu instead of windows. I have Windows 7 Professional 64-bit installed and just installed the 64-bit version of Ubuntu 13.04.

When installing Ubuntu on computers in the past, it provides a boot selection menu to select which OS to boot. In my case, it goes straight into booting windows.

I've tried going into the f12 boot menu but there is nothing helpful to select.

SOLUTION: Found this page on the Ubuntu site. https://help.ubuntu.com/community/Boot-Repair It involves using Boot-Repair as was also suggested below.

  • Where did you install the bootloader(Grub)? If your hard disk is /dev/sda that is where it should be installed. – To Do May 11 '13 at 12:03
  • I just followed the installation instructions which did not mention anything about the boot loader. – fvgs May 11 '13 at 12:11

Try booting through a liveDVD or live USB, install Boot-Repair by opening a terminal and typing as follows:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair

Try the Recommended repair option.


load from Live USB or DVD

  • chose try Ubuntu
  • once you get the friendly Ubuntu interface hit ctrl+T to bring up the terminal
  • run the following command # grub-install /dev/sda (or any disk you have sbd **)
  • boot your device and it will load Ubuntu normally
  • Welcome to Ask Ubuntu Islam! A couple of points on your answer: it's not "any disk you have", it should be on the disk that has Ubuntu on it. You wouldn't want him to install grub on an external hard disk. Also, the shortcut for terminal is Ctrl+Alt+T. – Alaa Ali Jun 8 '13 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.