My bookmarks are not shown anymore after upgrading to 13.04 Raring ringtails and I can't add any new bookmarks. The function is not shown and the shortcut Ctrl+D isn't working either. Is this functionality just gone for some reason (as the split screen with F3) or is there something wrong with my upgrade?

Thanks for any hints.

6 Answers 6


Nautilus bookmark settings

To manage bookmarks go to the Files menu in the panel to open the Bookmarks dialog. There we may enter a name and a path of a bookmark to appear in the Nautilus left side panel in the Bookmarks section:

enter image description here

Bookmark an opened directory

Alternatively open the directory you want to bookmark. Then click on the cogwheel top right to select "Bookmark this Location" or press Ctrl + D.

enter image description here

To remove a bookmark select "Remove"" from the right click context menu on the bookmark.

All our bookmarks will also be displayed as a quicklist:

enter image description here

Manual approach and removing default entries

Those bookmarks are stored in an editable file in .config/gtk-3.0/bookmarks where we may manually (or programmatically) add and remove path entries which take effect immediately. The examples above resulted in the following file content:

file:///home/takkat/Documents/My%20Bookmark My Bookmark
  • Hi, sorry but in the bookmarks dialog which i have, i can only rename or reorder my existing bookmarks which are not shown anyway. The "Bookmark this Location" entry in my menu is missing, CRTL-D is not working either (as mentioned in my question).
    – user157697
    May 12, 2013 at 7:09
  • Sorry i am not used to this interface, i am only allowed to edit my comments for 5 minutes which seems to me a bit odd. Anyway, what is mssing in my last comment is to say thank you for your detailed answer. Do you have any other suggestions ? Am I the only person with this problem ? Thx for your help.
    – user157697
    May 12, 2013 at 7:18
  • Ok, now i know what my problem was. I thought that the "add this location to bookmark" will be applied to the file/folder which is selected in the file manager. Now i realized that you have to go into the folder and then call this function (as you showed in your screenshots). I am not pretty sure but i think in the previous version this worked like I was expecting it.
    – user157697
    May 12, 2013 at 10:36
  • For me I actually don't see my bookmarks on the left panel. I have to go to the menu File > Bookmarks. Any idea how to get that to show ? Aug 21, 2013 at 15:33
  • 1
    @JJD: the shot was done on the host Ubuntu showing the VM window with default shreenshot tool using PrtSc key, then edited in Gimp. Little effort, max. outcome ;)
    – Takkat
    Apr 4, 2014 at 13:35

It's happened to me too. But I've had a Kernel Panic problem while upgrading from 12.10 to 13.04. I was able to restore my system, but none of my previous bookmarks were available.

It seems that the default folder where Nautilus saves bookmarks has changed. I restored them by copying my previous bookmarks from the file /home/yourusername/.gtk-bookmarks to /home/yourusername/.config/gtk-3.0/bookmarks. A simple text copy and paste using gedit.

  • oh blimey , no thanks god i had no kernel panic. My problem was a combination of the fact what you mentioned and the different logic while adding a new bookmark. thanks for your answer.
    – user157697
    May 15, 2013 at 5:07
  • i think your answer is one puzzle piece in this "new nautilus thing" in 13.04 raring ringtails.
    – user157697
    May 17, 2013 at 5:01
  • @YuriC see my post at bottom about those two files.
    – Dennis
    Oct 8, 2013 at 17:27

Even if you cannot add new item from the menu, you can edit the default one and surprisingly I just realized that CTRL+D will work to create a new one if you perform it in the desired location, however it is not presented in the menu.

  • Almost 9 years later ... getting this error launching nautilus from WSL and CTRL+D fixed it. Nice one! Oct 13, 2022 at 20:31

Here's another possibility. I had the same problem when updating to v13.04/GTK classic. The bookmark feature was simply gone. For a time, I thought that this very useful feature had just been removed. However, in the course of reconfiguring Brasero plugins I discovered the problem. I was starting Brasero from the command line since there was no menu entry created when I installed Brasero. I kept getting an error essentially telling me that Brasero couldn't access the bookmark file: Permission Denied. When I tried to check the permissions of ~/.config/gtk-3.0/bookmarks, I couldn't even open the .config folder. It turned out that the owner:group of .config and all its children had been changed to root:root with no access at all given to "Other".

I then recursively changed the owner:group of .config to me:me (sudo chown -R me:me .config). I also changed the file mode of directories to 775 and of any files to 664. This fixed the Brasero problem and also, magically, my bookmarks were back!

  • @ndefontenay see this post, it may help you.
    – Dennis
    Oct 8, 2013 at 17:26

I found that in Precise 12.04, I had to modify TWO files to get all the behaviors.

$HOME/.gtk-bookmarks This gave me the bookmarks in Nautilus

$HOME/.config/yourGTKVersion/bookmarks This gave me bookmarks in the file opening dialog box for all other applications.

Don't know if UBUNTU will keep them synced from ths point or not. I was moving my home directory from 10.10 to a new hard drive with 12.04. I had made the mistake of running for a LOOOOOOONG time on a non LTS (Long Time Support) version. Over a 6 month period, all my repos for updates vanished. I couldn't even get the latest PHP for my version. HAD to switch. And I needed to get back to developing code QUICK, needed bookmarks, etc.


in 13.10 I just realized that you can use CTRL+D...the shortcut is not presented in the menu but it works to create new bookmarks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .