I recently installed Ubuntu 13.0.4 Raring Ringtail onto my HP Pavilion G6, and I am having trouble compiling the drivers for my rtl8192ce wi-fi adapter. I've been searching around for a few days now and I haven't had any luck.

The driver I'm attempting to compile and install is here:


Here's the error I'm receiving when I attempt to run the "make" command:

make -C /lib/modules/3.8.0-19-generic/build M=/home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012 modules make[1]: Entering directory /usr/src/linux-headers-3.8.0-19-generic' CC [M] /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o In file included from /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:39:0: /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/pci.h:245:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtl_pci_probe’ /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: In function ‘_rtl_init_mac80211’: /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6: error: ‘IEEE80211_HW_BEACON_FILTER’ undeclared (first use in this function) /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6: note: each undeclared identifier is reported only once for each function it appears in /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: In function ‘rtl_action_proc’: /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:870:25: error: ‘RX_FLAG_MACTIME_MPDU’ undeclared (first use in this function) /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: In function ‘rtl_send_smps_action’: /home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:1432:16: error: ‘struct <anonymous>’ has no member named ‘sta’ make[2]: *** [/home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o] Error 1 make[1]: *** [_module_/home/addison/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012] Error 2 make[1]: Leaving directory/usr/src/linux-headers-3.8.0-19-generic' make: * [all] Error 2

Here is the information about my machine from "lspci -nnk | grep -iA2 net", "lsmod", "nm-tool", "nmcli nm status", "iwconfig", and "rfkill list all":

lspci -nnk | grep -iA2 net 01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01) Subsystem: Hewlett-Packard Company Device [103c:1629]

Kernel driver in use: rtl8192ce

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05) Subsystem: Hewlett-Packard Company Device [103c:1695] Kernel driver in use: r8169

lsmod Module Size Used by nls_utf8 12557 1 nls_iso8859_1 12713 1 isofs 39815 1 parport_pc 28152 0 ppdev 17073 0 rfcomm 42641 0 bnep 18036 2 bluetooth 228619 10 bnep,rfcomm snd_hda_codec_hdmi 36913 1 snd_hda_codec_idt 70256 1 joydev 17377 0 coretemp 13355 0 kvm 443165 0 ghash_clmulni_intel 13259 0 cryptd 20373 1 ghash_clmulni_intel snd_hda_intel 61623 1 snd_hda_codec 136453 3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel snd_hwdep 13602 1 snd_hda_codec arc4 12615 2 snd_pcm 97451 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel hp_wmi 18048 0 snd_page_alloc 18710 2 snd_pcm,snd_hda_intel sparse_keymap 13890 1 hp_wmi snd_seq_midi 13324 0 snd_seq_midi_event 14899 1 snd_seq_midi snd_rawmidi 30180 1 snd_seq_midi rtl8192ce 53594 0 rtlwifi 79673 1 rtl8192ce snd_seq 61554 2 snd_seq_midi_event,snd_seq_midi wmi 19070 1 hp_wmi rtl8192c_common 48779 1 rtl8192ce mac80211 606457 3 rtlwifi,rtl8192c_common,rtl8192ce snd_seq_device 14497 3 snd_seq,snd_rawmidi,snd_seq_midi snd_timer 29425 2 snd_pcm,snd_seq i915 600351 3 snd 68876 10 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device uvcvideo 80847 0 videobuf2_vmalloc 13056 1 uvcvideo videobuf2_memops 13202 1 videobuf2_vmalloc cfg80211 510937 2 mac80211,rtlwifi videobuf2_core 40513 1 uvcvideo video 19390 1 i915 soundcore 12680 1 snd drm_kms_helper 49394 1 i915 videodev 129260 2 uvcvideo,videobuf2_core rtsx_pci_ms 13011 0 mac_hid 13205 0 drm 286313 4 i915,drm_kms_helper lpc_ich 17061 0 psmouse 95870 0 lp 17759 0 i2c_algo_bit 13413 1 i915 memstick 16554 1 rtsx_pci_ms mei 41158 0 parport 46345 3 lp,ppdev,parport_pc microcode 22881 0 serio_raw 13215 0 ext2 72837 1 usb_storage 57204 1 mmc_block 27090 0 hid_generic 12540 0 usbhid 47074 0 hid 101002 2 hid_generic,usbhid rtsx_pci_sdmmc 17475 0 ahci 25731 3 libahci 31364 1 ahci rtsx_pci 33355 2 rtsx_pci_ms,rtsx_pci_sdmmc r8169 67446 0


NetworkManager Tool

State: connected (global)

  • Device: eth0 [Wired connection 1] ------------------------------------------- Type: Wired Driver: r8169 State: connected Default: yes HW Address: 78:E3:B5:6D:8C:FA

    Capabilities: Carrier Detect: yes Speed: 100 Mb/s

    Wired Properties Carrier: on

    IPv4 Settings: Address: Prefix: 24 ( Gateway:


  • Device: wlan0 ---------------------------------------------------------------- Type: 802.11 WiFi Driver: rtl8192ce State: unavailable Default: no HW Address: 20:10:7A:5D:5F:EE


    Wireless Properties WEP Encryption: yes WPA Encryption: yes WPA2 Encryption: yes

    Wireless Access Points

running connected disabled disabled disabled disabled

iwconfig eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off Encryption key:off Power Management:on

rfkill list all 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no 1: hp-wifi: Wireless LAN Soft blocked: no Hard blocked: yes 2: hp-bluetooth: Bluetooth Soft blocked: no Hard blocked: yes 3: hp-wwan: Wireless WAN Soft blocked: no Hard blocked: yes


Please help me solve this issue. Many thanks in advance to those who may have any advice to offer.

  • The driver rtl8192ce already is built in to 13.04 and, as you can see in lsmod, is loaded. However, in rfkill, we see that the wireless switch or key combination is set to turn the wireless off: "1: hp-wifi: Wireless LAN Soft blocked: no Hard blocked: yes" Please turn on the switch before you proceed.
    – chili555
    May 11, 2013 at 13:07
  • Not an expert in wifi but after I got mine installed after numerous attempts I found to activate it I had to enter in the terminal sudo modprobe rt2800 so for urcase just replace to "rt2800pci" with "rtl8192pci"
    – user140393
    May 11, 2013 at 19:27
  • The command modprobe is a program that turns on modules in the kernel. The command would not work if you don't have the proper drivers installed.
    – Alaa Ali
    May 12, 2013 at 5:23
  • did you solve this problem ? i have the same problem and i need a solution
    – Rachid O
    Sep 22, 2013 at 19:12

4 Answers 4


Download and try to compile this instead: https://dl.dropboxusercontent.com/u/54132482/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012.zip

Extract it, then run:

sudo make


sudo make install


sudo modprobe rtl8792ce

Then check your wireless. If it still doesn't work, reboot.


http://www.realtek.com This is a link to the manufacturer's website. Installing rtl8192ce driver.

1 - Scroll down until you see the package for rtl8192ceVA4 or rtl8188ce. (I prefer rtl8192ceVA4 but both work fine, can't tell the difference). Download the linux driver for the newest kernel.

2 - Extract the package to your home folder. Open the folder and locate "compat-wireless-3.2.5-1.tar.bz2" package. Copy, Paste, and Extract this to your home folder as well.

3 - Open the compat-wireless-3.2.5-1 folder, locate the "udev" folder copy and paste the contents of the udev folder (firmware rules and firmware script) to your home folder then use

sudo nautilus

so you can copy paste those into



` '/compat-wireless-3.2.5-1/compat/scripts'

4 - Go to '~/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/compat/script/' and copy paste

"compat-install.sh" to your home folder.

5- Next, edit the makefile for compat-wireless-3.2.5-1.

sudo gedit ~/compat-wireless-3.2.5-1/Makefile

Use the "search and replace" feature on the right of the gedit toolbar to replace all instances of "(MODPROBE) -l" without quotes with "(MODPROBE) " without quotes. The use of "-l" in this script will prevent installation and is why you get all those errors and whatnot, so get rid of it!

6 - Now run the following commands ignoring the errors as it should all work out when you are done.

sudo ./compat_firmware.sh

sudo ~/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/compat/3.2.5-1/scripts/unload.sh

sudo ~/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/compat/3.2.5-1/scripts/wunload.sh

sudo ~/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/compat/3.2.5-1/scripts/driver-select

sudo ./compat-install.sh

cd ~/compat-wireless-3.2.5-1

sudo su


make install

cd ~/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013


make install

sudo modprobe rtl8192ce

You may need to activate the hardware switch now (if you have one) but probably not. Save any unsaved work. Reboot. You should have wifi now. This install may help the kernel driver if it does not work properly (drops out frequently). Awesome reception in Debian Weezy compared to the nonfree repository package. This works great for Ubuntustudio 12.10 as well. I've used this on Weezy, Studio, and 13.10.

Good luck!

  • UPDATE FOR 13.10, 13.04, and 12.04 I ran into this link that fixes all the errors and installs perfect . . . link Awesome!
    – mchid
    Dec 13, 2013 at 17:33
  • I downloaded the dependency files from the instructions and then went to the git page, grabbed a copy of the zip file, cd into the folder, sudo make, sudo make install . . . reboot.
    – mchid
    Dec 13, 2013 at 17:36

Try the later version: http://dl.dropbox.com/u/57056576/DRIVERS/REALTEK/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012.tar.gz but are you sure you even need to compile it? 13.04 (Raring) worked out of the box for my 8723 chip, which previously needed the compilation. Type

locate rtl8723ae.ko

to see if the driver is present in the /lib/modules/... subdirectories. You should see one per kernel installation.

  • i have the 8723 chip and i can't compile the given driver in ubuntu 13.04, it gaves me the same error messages as him, any idea what can i do ?
    – Rachid O
    Sep 22, 2013 at 19:08

Have you seen this thread here: Realtek RTL8188CE desconects randomly and features slow connections

I have the rtl8188CE device and use the rtl8192ce driver as well. I was having disconnection issues and tried that thread. Connection has been strong and solid ever since following those instructions. Granted that I am using Ubuntu 14.04, but according to the bug report, this drive has issues with numerous kernels and this is the fix suggested there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .