I've seen this question asked many times before, and tried every single solution I found, yet none of them solved this problem. All my programming/computing knowledge comes from copying the solutions I see, so I do not know how or what I specifics I should be posting.

I installed UBUNTU on my laptop, and could not figure out how to change my password, someone else changed it for me and since then I've always had the .ICEauthority eorr, which I just skipped since it did not interfere with my work on the laptop. When it started to behave strangely I decided to update my version of Ubuntu.

I updated from version 10 to version 12, and since then the .ICEauthority error will not let me log in.

There is only one user on this computer, I cannot remove .ICEauthority for I have no permission. I cannot chmod or sudo anything because it "cannot resolve host" It asks for a password after that error and nothing happens.

There have been solutions that did not give error messages, and instead refused to return to the log-in screen if I tried ctr alt f7.

Right after the update it would not give an error and just did not log me in. Using a solution I got a different log-on screen, but the ICE error will not log me in.

If this is unsolvable, is there a way to retract files from this computer? I have tons of important .doc files stored in this laptop.

Thanks for the help in advance!


It is hard to know if you have a single or multiple problems, could be a number of issues.

I suggest you boot to recovery mode and drop to a root shell. Then run

chown -R $user:$user /home/$user

where $user is your user name. This should solve your ICE error which usually occurs when one does not use sudo or gksu properly. See https://help.ubuntu.com/community/RootSudo

If you need to recover data, boot any live CD and copy it over.

You may have other problems after the upgrade, hard to tell.

| improve this answer | |
  • I followed your instructions, and rebooted after putting in the chown command. I tried to log in again, but got the exact same error as before. What is a live CD? – Tjally May 10 '13 at 17:12
  • can you post the exact error message ? Also boot to recovery and ls -l /home/$user/.ICE* – Panther May 10 '13 at 17:13
  • The error that keeps me from logging in is: Could not update /home/lyan/.ICEauthority. And that command you've given me, do I use it after entering the first command? And boot to recovery means, restart in recovery mode, am I correct? – Tjally May 10 '13 at 19:48
  • yes, restart in recovery mode. Is your home directory encrypted ? – Panther May 10 '13 at 19:56
  • Not that I know of. – Tjally May 10 '13 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.