Every time I boot I get the "The system is running in low-graphics mode" error.

The problem is similar to this one: "the system is running in low graphics mode" I get this message when I boot my ubuntu, but I don't think I can use the answer, because I do not have the same graphics card (mine is Intel). I have searched Ask Ubuntu for a solution and tried some of the suggestions found here: How to fix "The system is running in low-graphics mode" error?.

I'm using an HP desktop with Ubuntu 12.04.

I have never had this problem before until about 12 hours ago. The only thing I can think of is that I had just installed about 35 updates via the update manager. The next time I switched on my computer I got the "The system is running in low-graphics mode" error.

Here is what I have tried:

  • Switching to gdm
  • After realising that I had used almost all my disk space I freed some by deleting a lot of movies and then rebooting.
  • Reinstalling ubuntu-desktop
  • Someone suggested editing the LightDM conf file, but I did not need to do this since the line was already unity-greeter

(It's tricky for me to copy any output and paste it here as long as I have this problem, since I can't get to the desktop etc.)

After trying all this, I chose to just reinstall Ubuntu (11.10). After doing that the problem was gone! But as soon as I upgraded to 12.04 and rebooted I got the error message again :(

Then tried removing the file /etc/X11/xorg.config.failsafe and restarted lightdm GUI server as in this answer. This did not help either.

I also tried running startx and got:

kb@kb-HP-Compaq-4000-Pro-SFF-PC:~$ startx
X.Org X Server 1.11.3 Release Date: 2011-12-16 X Protocol Version 11,
Revision 0 Build Operating System: Linux 2.6.42-37-generic i686 Ubuntu
Current Operating System: Linux kb-HP-Compaq-4000-Pro-SFF-PC
3.2.0-41-generic-pae #66-Ubuntu SMP Thu Apr 25 03:50:20 UTC 2013 i686 Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-41-generic-pae
root=UUID=f5d21c1a-a302-4688-948b-470818bfb967 ro quiet splash
vt.handoff=7 Build Date: 11 April 2013  01:04:30PM xorg-server
2:1.11.4-0ubuntu10.13 (For technical support please see
http://www.ubuntu.com/support) Current version of pixman: 0.24.4
      Before reporting problems, check http://wiki.x.org
      to make sure that you have the latest version. Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (==) Log file: "/var/log/Xorg.0.log", Time: Thu May  9 22:35:42 2013
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

 Fatal server error: no screens found

 Please consult the The X.Org Foundation support
          at http://wiki.x.org  for help. Please also check the log file at "/var/log/Xorg.0.log" for additional information.

   ddxSigGiveUp: Closing log Server terminated with error (1). Closing
 log file. xinit: giving up xinit: unable to connect to X server: No
 such file or directory xinit: server error

I hope some of this info helps.

  • 1
    In System Settings -> Displays it says "Laptop", which seems weird since I'm using a desktop.
    – 1kb
    May 10, 2013 at 15:51
  • My personal experience was: Installing "PDF Mod" program (pdfmod) triggers "The system is running in low-graphics mode" ugly error, on system start. Uninstalling pdfmod recovers the system.
    – kierotetas
    Apr 12, 2018 at 22:02

3 Answers 3


I had the same issue from updating. It seemed like xorg broke from not having a config file. Nor can it be auto-generated so I copied the xorg.conf.failsafe and made a new xorg.conf. Let me know if that helps.

I notice you deleted that file. This is what mine looks like. I am working on get this auto generation to work though.

Section "Device"
   Identifier  "Configured Video Device"
   Driver      "fbdev"

Section "Monitor"
   Identifier  "Configured Monitor"

Section "Screen"
   Identifier  "Default Screen"
   Monitor     "Configured Monitor"
   Device      "Configured Video Device"
  • I made a new xorg.conf file and xorg.conf.failsafe and copied the text from the failsafe to the xorg.conf as you said. Now my computer boots without the "low-graphics" error! Thank you! Before I had to reboot and chose "recovery mode" and then chose continue in normal mode, which took ages. But could this fix somehow be the reason why the pc internal speaker is suddenly on even though my computer is connected to my stereo? This has never happened before.
    – 1kb
    May 18, 2013 at 10:46


I also have an HP Compaq 4000 Pro SFF, running Ubuntu 12.04 LTS.

I just experienced the same issue ..


I tried copying the missing xorg.conf file back from failsafe version, which appears to resolve.


[ login to text-mode eg. Ctrl-Alt-F1 ]

cd /etc/X11/
sudo cp xorg.conf.failsafe xorg.conf

sudo shutdown -r now


  1. What was the root cause?

  2. What is the downside to adding ppa:ubuntu-x-swat/x-updates

  3. What did I lose, from my old xorg.conf file?

UPDATE: 19-May-2013

from: @scott's answer to "the system is running in low graphics mode" I get this message when I boot my ubuntu

  1. Don't attempt to restore missing xorg.conf file, as it is not needed.

    This is apparently an issue (bug?) with lightdm, which 'reacts badly' to the missing xorg.conf file.

  2. REMOVE errant xorg.conf.failsafe file, to stop lightdm from making bad assumptions.


[ login to text-mode eg. Ctrl-Alt-F1 ]

cd /etc/X11/
sudo mv xorg.conf.failsafe xorg.conf.failsafe.safe

[ skip next line, if you are still missing this file ]
sudo rm xorg.conf

sudo shutdown -r now


Intel driver unstable. Random logouts, desktop glitches.

Working to resolve ..


This simple fix removed the error completely on 2 machines with Intel graphics on Xenial (16.04):

  1. sudo xdiagnose
  2. Check "Disable bootloader graphics" in section "Workarounds"

enter image description here

From the docs:

The grub bootloader has a graphics mode using the VESA framebuffer driver which can sometimes interfere with later loading of the proper video driver. Checking this forces grub to use text mode only.

Please leave a comment if this works for you. Trying to solve this for 4 days straight and trying every suggestion out there I found this fix by accident.

Not the answer you're looking for? Browse other questions tagged or ask your own question.