I had some problems with shutdown/restarting Ubuntu 13.04. It used to hang in a black screen with some codes about speech dispatcher. I searched the web and found a solution:

sudo nano /etc/default/speech-dispatcher

Inside the file I changed the RUN property to yes, so the file started looking like this:

# Defaults for the speech-dispatcher initscript, from speech-dispatcher

# Set to yes to start system wide Speech Dispatcher

I did so, the problem was solved but it disabled my internal speaker and mic. It looks like I have to choose between proper shutdowns and working mic/speaker.

Is there any solution to have them both working?

Hardware: DELL Inspiron n5110

Distro: Ubuntu 13.04 64bit

  • solved by removing speech-dispatcher from start-up apps.
    – Amir A
    May 10, 2013 at 2:09
  • @AmirA The AskUbuntu way of acknowledging an answer is to vote it up and mark as accepted. After which comments could be deleted. :)
    – geezanansa
    May 14, 2013 at 0:16

4 Answers 4


You don't need to uninstall/remove the speech-dispatcher to achieve a proper shutdown. Just remove it from automatic start/stop at the time of system boot/shutdown.

Use the command:

sudo update-rc.d -f speech-dispatcher remove

Unless you need speech-dispatcher, you can just disable it. I installed Boot-up-manager:

sudo apt-get install bum

..and then I disabled speech-dispatcher:

enter image description here


I had an issue with rebooting and would get errors about speech dispatcher and using BUM and disabling it worked but I don't think my built in mic works. I'm on a HP tc4200 with ubuntu 12.04 and loving it.


Open file /etc/default/speech-dispatcher on your favorite editor with sudo.

Example: sudo nano /etc/default/speech-dispatcher





Restart and you are ready.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.