2

I'm new to Ubuntu 12.04 (only installed it on Sunday), and enjoying what I have been learning, but having a bit of a problem!

I want to get my Sony Cybershot W510 to connect to the computer. I do have a card reader which I can use if necessary to get the photos off, but would be nice to get the camera working (I'm a perfectionist!)

I plug it in, and press the play button (as this is what the camera instructions say to do) but nothing happens.

I know my USB devices work fine, because plugging in a USB Memory Stick or USB Hard Drive results in the device appearing on the desktop so I can use it. Even my iPOD will mount, which I'm led to believe is tricky enough!

I would be grateful if someone could walk me through getting this connected! I am fairly good at the technical side of things, so don't be afraid to do your worst!

2

The Sony Cybershot looks like it operates in MTP mode by default. To fix this easily, try changing the settings in your camera to operate as a "Mass Storage Device" instead.

As per this article, choose Menu, Settings, Main Settings, USB Connect, then choose Mass Storage.

Alternatively you can try to get MTP working in Ubuntu, which is a little trickier.

This article worked for me and my Nexus 7 which only really works with MTP. Basically, do

sudo add-apt-repository ppa:langdalepl/gvfs-mtp
sudo apt-get update
sudo apt-get upgrade

Then try plugging in your Cybershot (make sure you change the camera settings back to MTP if you tried my first suggestion).

  • Hi Scaine, I have previously tried with Mass Storage and it doesn't work. I'll have a stab at setting up MTP like you suggested and let you know the outcome. – Sam H May 9 '13 at 18:57
  • Good luck! My Nexus 7 works perfectly after following that guide. – Scaine May 9 '13 at 18:59
  • Didn't work. I even restarted my system to make sure. Now what? – Sam H May 9 '13 at 19:06
  • I'll have a check tonight (busy at the mo) at how I got my MTP working again - was sure it was that article though, and if it was I'm not sure how I can help. – Scaine May 9 '13 at 19:48
2

Tried to connect my Sony Alpha 5000, but it dosn't workd. It was the missing driner. Just install

sudo apt-get install exfat-fuse

In the Camera select in the options as USB-conection "auto".

  • This solution worked for my Sony DSC-HX80 – user1002119 Mar 29 '19 at 3:30
0

Try to install gphoto2. search for it in software center or open a terminal and type

sudo apt-get install gphoto2

then try to connect your camera again.

  • Ok, tried that, and got this: E: Unable to locate package libgphoto2 – Sam H May 9 '13 at 18:44
  • try again, i edited the command above. I'm sorry but i'm not on an Ubuntu machine right now and i can't check if something works before i post it :$ – Nikos Kalomiris May 9 '13 at 18:51
  • Ok, I ran the command and it seemed to install ok. Connected the camera and still nothing happened. I went into the menu on the camera and set it to use PTP for USB connectivity rather than Mass Storage, but still doesn't work. Just to be clear - would something pop up on my screen if I connected the camera? – Sam H May 9 '13 at 18:55
0

Ok everyone,

Camera is now working! The problem was that I had lost the original cable for the camera, and I ordered a cheap replacement on eBay, which wasn't doing the trick. Now that I have replaced this cable with an original Sony cable, all is well!

0

I just connected Ubuntu 18 with my Sony alpha 6000 with USB and darktable Here the download link:

https://www.darktable.org/install/

Darktable is an excellent digital image editing software with tethering capabilities. Apparently this software allows connection to cameras via USB and certainly has built in picture organization capabilities. Although darktable is real bummer concerning its professional capabilities, it is relatively unknown.

kind regards Al

  • 3
    Hello and welcome to AU. Could you summarize the key points of the link you refer to so that your answer remains valid even if the link disappears? – Marc Vanhoomissen Sep 17 '19 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.