I installed gnome shell and when i did the cairo dock is not opening at all it opens the maintenance mode and i can not edit the preferences i want to uninstall it and reinstall maybe it'll help ti fix it or if anyone have any idea that would help
I installed it from sofware center and i tried purge and it wasn't worked

I tried cairo-dock -ol debug and that was the output


I installed it, on my system just to see how it works, and I removed it. This how I did it:

To completely remove Cairo dock, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get purge cairo-dock cairo-dock-plug-ins && sudo apt-get autoremove

And to install:

sudo add-apt-repository ppa:cairo-dock-team/ppa
sudo apt-get update
sudo apt-get install cairo-dock cairo-dock-plug-ins

Also if you have Synaptic Package Manager installed, you can search for cairo-dock, and unckeck cairo-dock and cairo-dock-plug-ins.

You can go back to the USC, and remove Cairo Dock.

I just tried it on another machine, and tried the first command, install it form the USC it, and it was removed.

If it starts in maintenance mode, then do this:

Quit Cairo-Dock Remove this:


Launch Cairo-Dock in a terminal with :

cairo-dock -o

If you have the maintenance mode again, can you launch Cairo-Dock with

cairo-dock -ol debug

and post the output

One last thing. Install synaptic package manager if you don't have it installed. You can install it by just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install synaptic

Once installed launch it from dash, and when it opens search for Cairo

enter image description here

Highlight all Cairo entries

enter image description here

Right click, and choose Mark for Complete Removal

enter image description here

  • it did not worked, the command purge uninstalled it but when i reinstalled it it gave me the maintenance mode – Akram Lazkanee May 9 '13 at 10:30
  • I just added the info if it starts in maintenance mode. – Mitch May 9 '13 at 17:51
  • i tried to delete that folder and it didn't worked so i just added the output, and it was too long so i cut some of it in the beginning so i can post it – Akram Lazkanee May 9 '13 at 18:02
  • I fixed the post for you, and I have added more info in the answer. Take a look at it. – Mitch May 9 '13 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.