I manually installed LuxRender 1.2.1 under /usr/local/bin/ and it works fine and dandy. I then created 5 new mime-types for LuxRender *.lxs, *.lxo, *.lxm, *.lxv and *.flm file formats (scene, objects, materials, volumes and film). I created them with assogiate for convenience, however here is the simple generated Override.html file:

<?xml version="1.0"?>
<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
    <mime-type type="text/x-luxrender-scene">
        <glob pattern="*.lxs"/>
        <comment>LuxRender Scene</comment>
    <mime-type type="text/x-luxrender-materials">
        <glob pattern="*.lxm"/>
        <comment>LuxRender Materials</comment>
    <mime-type type="text/x-luxrender-objects">
        <glob pattern="*.lxo"/>
        <comment>LuxRender Objects</comment>
    <mime-type type="text/x-luxrender-volumes">
        <glob pattern="*.lxv"/>
        <comment>LuxRender Volumes</comment>
    <mime-type type="image/x-luxrender-film">
        <glob pattern="*.flm"/>
        <comment>LuxRender Film</comment>

Then, I ran update-mime-database ~/.local/share/mime, which updated the file mime.cache. The mime-types now works (both tested with mimetype and in the Nautilus properties panel of a file).

Now I want to associate the icons (which come with LuxRender as 256x256 png files). I resized them to the apropriate sizes and put them under /usr/share/icons/hicolor/??x??/mimetypes. Finally, i refreshed the cache with sudo gtk-update-icon-cache /usr/share/icons/hicolor.

If I open assogiate, it displays the correct icons even if I haven't explicitly defined them. However, Nautilus does not. Since I'm using Ubuntu-mono-dark (which however inherits from hicolor), I thought that it was because I had to put them under /usr/share/icons/Ubuntu-mono-dark too, or maybe /usr/share/icons/Humanity. However, this doesn't work neither.

The strange fact is that if I switch my theme to hicolor, the new icons actually shows up! This seems to suggest that they are installed correctly...

Does anyone have an idea about what is happening? Where do I have to put the icons? What should I configure?

PS: just as a side note, I had the same problem with Mathematica icons...


I fixed it. I installed them under gnome, Humanity, Humanity-Dark, ubuntu-mono-dark... and finally got it work. I really don't care to know how does this work... It seems to me that the Inherits= line in index.theme does never fall back to hicolor.

  • Placing your custom icons into /usr/share/icons/Humanity/ was enough. – whtyger Mar 31 '16 at 13:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.