I have the following configuration:

  • CPU: amd athlon 64bit
  • Motherboard: Phoenix with awardBIOS v6.0 APIC mode = disabled
  • Video card: GeForce 5500
  • Sound card: soundblaster live 24bit
  • RAM: 1.5GB


  • ext3 32GB where I installed Ubuntu.
  • Swap 500MB.
  • 180GB Fat32 unmounted. contains data only.

I installed Ubuntu 10.10 and used the "Additional driver" program to get the nVidia proprietary drivers.

The system works for sometime and randomly freezes. The mouse and keyboard are not responding and I am not able to do a SSH. The only solution is pressing the power button.

I tried Kubuntu 10.10 and 32/64-bits versions as well.

There is nothing in the logs to suggest what the reason might be.

Any help will be appreciated. Thanks in advance.

here are the logs:

  • Can you post the /var/log/{kernel.log,Xorg.0.log,syslog} files on paste.ubuntu.com and place the links in your question? – Lekensteyn Mar 6 '11 at 14:17
  • I will add the logs when I will manage to get into ubuntu. Now I am not able to boot. – albert green Mar 6 '11 at 15:59
  • I tried to install again, I got a freeze during install. I changed the RAM. same thing. Changed the HDD, same thing. Removed audio card, same thing. video card if the one left, but it is working perfectly on a windows box. – albert green Mar 6 '11 at 16:01
  • video card's fan stops randomly. chip heats up, ubuntu freezes. I will change the card and confirm. the strangest thing though is that this card behaves the same way on windows and windows XP doesn't complain at all. – albert green Mar 6 '11 at 17:45
  • changed video card to GeForce 6200 and I have the same effect. Ubuntu freezes during install. Ubuntu freezes randomly if I run it from the DVD. – albert green Mar 6 '11 at 23:49

After I tried many things I finally think that I discovered the problem. Actually in the logs I noticed the following lines.

Mar  6 23:31:11 ubuntu kernel: [  148.400120] Marking TSC unstable due to cpufreq changes
Mar  6 23:31:11 ubuntu kernel: [  148.400194] Switching to clocksource acpi_pm

Since I have an old motherboard with an old bios, I though maybe the power management was not working correctly. I deactivated everything related to that in my bios, and found this :


so I added the acpi=off when booting from the liveCD in order to be able to complete the installation. It worked. Then I added acpi=off in grub. I used a Kubuntu 10.10 installation, and Kubuntu doesn't have a rc.conf, so setting this value is done like this:

edit the /etc/default/grub file and add acpi=off like this:

GRUB_CMDLINE_LINUX_DEFAULT="**acpi=off** quiet splash"

Must be edited as root.

Then run:

sudo update-grub

Then reboot.

At the moment of this writing, the system has an uptime of 15 hourrs without freezing. I run stress tests, videos, audios and everything looks fine.

The logs do not contain the strings like before.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.