2

while trying to build hostapt I get the following error.

make
../src/crypto/tls_openssl.c:17:25: fatal error: openssl/ssl.h: No such file or directory
compilation terminated.
make: *** [../src/crypto/tls_openssl.o] Error 1

I am trying to create a infrastructure mode hotspot with Ubuntu 13.04 without using router, mainly for my android phone.

I am using this guide.

  • Install libnl1, sudo apt-get install libnl1 as described by the guide you're following. – Basharat Sialvi May 8 '13 at 8:07
  • done that, but the error still shows. – mojo May 8 '13 at 8:30
  • done that too. same error, – mojo May 8 '13 at 8:59
  • Ok! Try installing one of these packages: libssl-dev or python-pyopenssl. – Basharat Sialvi May 8 '13 at 9:22
  • ok. now its this :~/hostap/hostapd$ make CC ../src/crypto/tls_openssl.c CC ../src/crypto/crypto_openssl.c /usr/bin/ld: cannot find -lnl collect2: error: ld returned 1 exit status make: *** [hostapd] Error 1 – mojo May 8 '13 at 10:14
5

This solution came from the comments of the above post. (The reason I am writing a solution instead of a comment is I do not have the reputation currently to write a comment and I wanted to let people know that this worked for me).

I installed libssl-dev using:

sudo apt-get install libssl-dev

Then I ran

make clean

Then

make

After this it worked for me. Thank you to above commenters for clearing that up.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.