2

I'm using ubuntu 13.04 and got VERY bad 3d performance with intel ironlake comparing with a windows installation.

Is there any way I can improve this?

I already tried various paramaters of the i915 kernel module, but that didn't help much... SNA is already enabled.

1

Add the following option in grub file

i915.semaphores=1

Then

 sudo update-grub

Mine is

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.lvds_downclock=1 drm.vblankoffdelay=1  i915.semaphores=1"

Try adding this to /etc/environment

 CLUTTER_PAINT=disable-clipped-redraws:disable-culling

[RESOLVED] Poor performance on Ironlake compared to old Intel GPU Intel Ironlake OpenGL Performance On Mesa 9.1

0

Download and install the official graphics drivers for all intel processors. I had some minor problems with some games but this solved that issue.

https://01.org/linuxgraphics/

These drivers are given by Intel Open Source Technology Center and are always updated. Don't forget to add their source in your source list, to always get the updated drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.