I used powertop v.2.1 under Ubuntu 12.04 but it missed the power est. column.

It's the same situation as described here‎ and that bug is supposed to be fixed already.

I tried lm_sensors but it didn't give any voltage reading. Here's a log for sensors-detect and sesnors.

I am uncertain what caused the problem. I am running linux kernel 3.2.0-23-generic, Ubuntu 12.04 distro on Lenovo thinkpad machine.

Are there any other Linux utility to monitor power consumption for different devices?

  • I think powertop is the only solution what you are looking for, check the new version – Qasim May 7 '13 at 6:50
up vote 7 down vote accepted

If you newly installed PowerTop, give it some time... It takes a few days to get the estimates correct and then starts displaying. I found this info on the net and also speak from experience...

  • You're right on this, but do you know why it works in this way? – Kevin Q May 7 '13 at 15:35
  • 1
    I suppose it simply needs to collect the relevant data before starting to estimate the power consumption. Just the way the battery indicator estimation gets better with time. – charlie May 8 '13 at 7:21
  • Also, please vote up the answer you like. – charlie May 8 '13 at 8:02
  • 1
    Do I have to keep it open or it is collecting that in background? – michelpm Dec 20 '14 at 14:51
  • 1
    It can do it in background but may take a few days.. So be patient – charlie Dec 21 '14 at 2:58

Powertop 2.3

You can also install Powertop 2.3 hope this bug is fixed

You need to download and compile it because no one have the latest version

Download powertop https://01.org/powertop/downloads/2013/powertop-v2.3

powertop-2.3.tar.gz < < < Click & Download Me

Before compiling you need to install dependencies

Installing Dependencies ( Just copy paste the following commands )

sudo apt-get install libtool autoconf libnl-dev ncurses-dev pciutils-dev build-essential -y

Installing Powertop

To build and install PowerTOP type the following commands,

cd Downloads/powertop*  # assuming that you have downloaded in Downloads folder in you home directory   
sudo configure 
sudo make       # use -j option if you want to see details below
sudo make install

You can also use -j2 for how many cores you want to use in ./make.Replace -j2 with whatever number of CPU cores you want to use for the compilation process. for example i have used ./make -j8

How do I make Powertop changes permanent?


Powerstat

is a command line tool that shows you your system power consumption in watts.

Install Powerstat

ssudo apt-get install powerstat -y

You can check your power consumption by

  sudo powerstat

OR

 sudo powerstat -d 0

It will shows power consumption in watts

Running for 480 seconds (48 samples at 10 second intervals).
ACPI battery power measurements will start in 0 seconds time

Time    User  Nice   Sys  Idle    IO  Run Ctxt/s  IRQ/s Fork Exec Exit  Watts
 11:19:41   4.2   0.0   1.4  94.4   0.0    1   8731    518   20   20   20   9.44
 11:19:51   1.6   0.0   0.9  97.4   0.0    1   2165    301   20   20   20  10.78
 11:20:01   1.7   0.0   1.0  97.3   0.0    1   7788    400   20   20   20  12.27

Average   2.5   0.0   1.1  96.3   0.0  1.0 6228.0  406.3 20.0 20.0 20.0  10.83
StdDev   1.2   0.0   0.2   1.4   0.0  0.0 2898.3   89.0  0.0  0.0  0.0   1.16

 Minimum   1.6   0.0   0.9  94.4   0.0  1.0 2165.4  300.6 20.0 20.0 20.0   9.44
 Maximum   4.2   0.0   1.4  97.4   0.0  1.0 8730.7  518.3 20.0 20.0 20.0  12.27

 Summary:
 10.83 Watts on Average with Standard Deviation 1.16  

  • I compiled the latest source, but the problem is still not resolved. Powerstat is not what I'am looking for since I need to read voltage or power consumption for different devices. – Kevin Q May 7 '13 at 8:30

I try to compile powerstat on kubuntu 12.04 (3.5 kernel) with the guide posted by Qasim. But i always get Errors after ./configure. Error: Can't find libnl and lib-genl.

  • I have compiled 4 5 times ... never get error compiling ...paste me the exact error so i can fix it – Qasim May 21 '13 at 0:10
  • sudo apt-get install libnl-dev libnl-genl-3-dev – Qasim May 21 '13 at 0:15
  • Thats the error code: code checking for pkg-config... no checking for PCIUTILS... no checking for library containing pci_get_dev... -lpci checking for LIBNL... no checking for LIBNL... no checking for LIBNL... no configure: error: libnl and libnl-genl are required but were not found – Bullseye May 21 '13 at 18:53
  • 1
    And that after i try to install libnl-dev libnl-genls-3: libnl-dev is already the newest version. Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libnl-genl-3-dev : Depends: libnl-3-dev (= 3.2.3-2ubuntu2) but it is not going to be installed E: Unable to correct problems, you have held broken packages. – Bullseye May 21 '13 at 18:58
  • powertops 2.1 works fine – Bullseye May 21 '13 at 19:03

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.