3

On Ubuntu, I'm trying to mount my USB

[] dmesg
... USB Mass Storage support registered.
... scsi 2:0:0:0 Direct-Access Kingston DataTraveler 2.0
... sd 2:0:0:0 [sdb] 15679488 512-byte logical blocks: (8.02 GB/7.47 GiB)
... sd 2:0:0:0 Write Protect is off
(so I assume that /dev/sdb is my USB pendrive)

[] mkdir /mnt/usb
[] mount /dev/sdb /mnt/usb
mount: mounting /dev/sdb on /mnt/usb failed: Invalid Argument

I also tried with "-t ext4" with no success. What am I doing wrong? Thank you very much.

  • Please add the output of sudo fdisk -l to your question. – Basharat Sialvi May 6 '13 at 20:19
  • 1
    I think it should be mount /dev/sdb1 /mnt/usb. – Eric Carvalho May 6 '13 at 20:20
  • 2
    @EricCarvalho You should add that as an answer ;-) – Seth May 6 '13 at 20:33
  • 1
    Instead of adding [solved] to the title please accept the correct/useful answer by clicking on the check-mark beside it. – guntbert May 7 '13 at 13:29
4

/dev/sdb represents the whole storage device. The individual partitions are addressed by numbers following the device name, e.g. sdb1 is the 1st partition in the storage device sdb. As USB flash drives usually have only one partition, the mount command should be:

mount /dev/sdb1 /mnt/usb
1

sda or sdb is just the name of your storage device, if you want to mount it you must enter the partition number too.

mkdir -p /media/usb
mount /dev/sdb1 /media/usb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.