I've got an IMAP mail server running dovecot.

I use several different mail clients -- K-9 mail on my Nexus One, and RoundCube Webmail when I'm not on my main computer.

On my main computer, I use Evolution. However, it doesn't show the latest emails on the server. I can see them with other clients; just not Evolution.

Is there a way to force Evolution to re-load the entire folder?


There are several settings for an IMAP account you can make in Evolution. On first startup, or when you create a new account, or in case you already have an account by selecting Edit -> Preferences -> Mail Accounts -> account@provider -> Edit -> Receiving Options you will be presented the following options:

enter image description here

The settings given here make sure that all mails are displayed in Evolution. As soon as you check only subscribed folders, start to apply filters, or check for junk mails you risk that only part of your mails are displayed.

Only if there is no success with settings then as a last resort you may have to delete the local IMAP folder to force reloading as has already been suggested.

| improve this answer | |

To force evolution to reload the entire IMAP account is to delete the IMAP folder in the hidden evolution folder in your home folder while evolution is closed.

IMAP folder

Alternatively if you have multiple IMAP accounts you can go in to the IMAP folder and delete the folder pertaining to that account.

IMAP Account folder

This will force evolution to reload the entire account.

Hope this helps.


It sounds as though the account has been set-up as a standard IMAP account as a posed to an IMAP+ account. What's the difference I here you say (because if your here you will need to know).

IMAP+ in Evolution is an IMAP IDLE enabled account which means that the client can tell the server to immediately sync all mail meaning that manual or automatic periodic syncing are obsolete.

With this type of account you should see the email as soon as it has arrived with your server.

Due to a bug that is now fixed in 2.32 (the standard version in 10.10 is 2.30.3) you need to check the "Use idle if the server supports it" option in the options tab.

| improve this answer | |
  • My folders where not as pictured but in .cache/evolution/mail – jsta Nov 16 '16 at 19:24

I had exactly the same problem with Ubuntu 19.04 and Evolution 3.321.-12 using sustem online accounts. After removing local computer account from Evolution, it started to work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.