I have Samsung R780 laptop (Core i5, NVidia) on which I had run Ubuntu successfully (save for glitchy wireless) for two years. However, after last upgrade the installation broke, and I cannot even login in the text mode any more. During the upgrade, many errors were thrown, and eventually it exited saying upgrade was incomplete. I tried the option with partial upgrade. After the restart it would get stuck on the loading screen (purple with dots), and wouldn’t go past that to login screen (no HDD activity, Ctrl + Alt + function keys that would switch between consoles just show blinking cursor).

I’ve tried recovery options (enable networking, and try repairing broken packages), but it ignores or cannot find the repositories. In the end it says it cannot parse package lists, and write to couple directories. Same thing happens during apt-get update from the root shell. Likewise, it cannot check the file system. While trying these options, it displays error messages saying this or that package or library was not found, as if upgrade deleted some stuff without replacing it, I assume. Several recovery options resulted in the following error message:

error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory

I’ve tried nomodeset option in GRUB, it didn’t help any. When I removed quiet and splash options (by the way, splash option was written in twice for some reason), I’ve got the following message (sic) on which the boot hangs:

init: mountall main process (326) terminated with status 127hared object file: No such file or directory

  • tried nomodeset?? possibly stuck at purple screen because of nvidia driver needs to be reinstalled. – Web-E May 6 '13 at 5:48
  • @Web-E, see edit, please. – theUg May 6 '13 at 9:52

It appears to have been quite a simple fix in the end.

Get to a root console and type: 'apt-get update && apt-get upgrade'

Hopefully you will see that 'nvidia-current' has been held back.

'apt-get install nvidia-current' should then fix your issue.

(edit: I just read that apt-get update doesn't work for you - luckily I escaped this. Not sure how to approach that - I too had issues writing to apt-controlled directories but they seem to have magically disappeared).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.