30

My OS is Lubuntu 13.04. After 10 mins of inactivity the screen goes black. What I did to stop it without effect:

  • uninstalled xscreensaver completely
  • in power setting I set to never blank the screen
  • run some command found in the internet with "xset" which was said to solve it (but maybe it was wrong command, if you know proper please write it)

And still nothing. I don't know why lubuntu wants so hard to keep going black when watching films. For example on kubuntu/ubuntu I just set in power settings to never go black and it works. Maybe lubuntu uses customized kernel with hard-coded extreme energy savings that can't be turned off?

3
  • See my solution here: askubuntu.com/questions/351849/…
    – Magno C
    Oct 9, 2013 at 18:38
  • 1
    I can confirm this behaviour for Ubuntu 14.04 after Upgrade from 13.04. The trick by TenPlus1 is working for me.
    – user273218
    Apr 24, 2014 at 9:44
  • Installing xfce4 to avoid turning the screen black? That's ridiculous. You could try at least this simple script before insalling a complete desktop manager just for the screensaver (which turns on when you don't use the computer): ubuntuforums.org/showthread.php?t=2251377&highlight= Feb 17, 2015 at 15:42

12 Answers 12

19

In Lubuntu it is an option in preferences called "Light Lock". It's annoyingly on by default.

2
  • 3
    I believe this is the correct answer. But I recommend expanding this to explain exactly where to find that, perhaps even with a screenshot. Aug 22, 2014 at 22:07
  • 4
    This is the correct answer for sure. I've found this in Main menu button (on panel)-> Preferences >> Light Locker Settings Mar 15, 2015 at 19:31
18

Try installing :

sudo apt-get install xfce4-power-manager

then configure it in:

xfce4-power-manager-settings 
3
  • 1
    Why you think he should install xfce4-power-manager?
    – Braiam
    Feb 13, 2014 at 2:28
  • it works for me. Easy and simple solution. Feb 13, 2014 at 2:35
  • On ubuntu 14.04 this doesn't work
    – Ghita
    Jan 2, 2015 at 18:27
9

For a temporary fix pop into terminal and type:

xset s 0 0

and this should stop the 10 minute blanking problem, to make it more permanent, insert a line with the same command at the start of the /home/username/.profile file.

3
  • why is it temporary solution? Is it like running this command disables the blanking only for current session? May 5, 2013 at 21:42
  • Or xset s off
    – qed
    Nov 9, 2013 at 19:54
  • 3
    You can always disable Energy Star features: xset -dpms
    – swietyy
    Oct 1, 2014 at 21:04
3

Helps for me after reboot. In /etc/X11/xorg.conf (if you not have it just create):

Section "Monitor"
    Identifier "eDP0" <<< or LVDS0 or VGA0 or ...
    Option "DPMS" "false"
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection
1
  • the only one that worked for me after updating my 14.04. thx.
    – smertrios
    Jul 27, 2015 at 21:57
1

In Ubuntu Mate 15.10 x64, I had the same issue. In the upper corner of Mate, Go to System > Administration, then to LightDM GTK+ Greeter Settings and enter your password. In the next window, click upper right on Misc., there you will find Timeout Until The Screen Blanks and it will be set at 1 Minute by default. Just move the slider to the left to Never. This may also be the case in Lubuntu, but it was definitely the issue in Mate 15.10.

1
  • LightDM GTK+ Greeter Settings has been renamed to Login in Mate > 18.04, and unfortunately the screen blanking setting no longer exists
    – Windigo
    May 11, 2020 at 18:19
1

Lubuntu 16.04 LTS. I tried following the instructions from Arturo Veras by installing xfce4-power-manager. When I tried, it said it was already the latest version so I ran it. It's the same as going through the menu:

Lubuntu | Preferences | Power Manager

I tried it before finding Arturo's information, but apparently, I didn't do something right. This time, I set the following settings under "Plugged In"

Blank After: Never Put to sleep after: Never Switch off after: Never On inactivity reduce to : 80% Reduce after: Never (But, I may change this one.)

I went to supper, ate, cleaned dishes, made smoothies and sat down to write this and it still hasn't gone blank. :)

In the Lubuntu 16.04 LTS install from the live flash drive, Xfce Power Manager was automatically installed so I didn't need to do the command line.

I hope this will be helpful to the next GUI minded user.

0

I believe I've found a solution to this problem. I've recently update from Ubuntu Mate 15.04, in which the black screen made me crazy, to 15.10, with a new installation. With the new version, after I set it up the screensaver off, everything seemed to work fine, no black screen at all. After that, I made a few customizations of the system, the last one of which was to delete from the startup applications, the power manager (I use a desktop pc so I thought that was a useless waste of time to run it). After that, and after a reboot, the hated black screen shown itself again. So I created a new startup application named Power manager and I set "mate-power-manager" as command. This simply solution worked for me and I believe that I got the problem in 15.04 for the same reason. Hope this helps.

1
  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Jan 10, 2016 at 12:32
0

In Greenie Linux (based on Lubuntu) I removed both xscreensaver and lightlocker and installed gnome-screensaver and added it to autostart.

1
  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Also, non-official derivatives of Ubuntu are kind of off topic on AskUbuntu. Jul 31, 2016 at 9:27
0

There is an app caffeine to manage display switching off (and screensaver).

sudo apt-get install caffeine

After installation you need to run a command caffeine-indicator. Then you will have an icon in tray. Click it and select Activate in popup menu to prevent display to switch off. If then you would like to allow display to switch off again you should click on caffeine tray icon and select Deactivate in menu.

0

While viewing videos on my htpc, the screen would blank after 10 minutes with no keyboard/mouse input. Obviously not desirable behaviour for an htpc. Turning off screensavers and power saving did not have any effect. Eventually, my web searches led me to believe this was caused by the xserver. I tested this by running the following:

xset s off && xset -dpms

in a terminal at the beginning of a session and confirmed that this did eliminate the undesired screen blanking. Running xset -q in the terminal confirms DPMS (Energy Star) was disabled.

In order to avoid having to open a terminal and run this command at the start of each session, I set this to run at system boot. The screen blanking was back and xset -q showed DPMS enabled. Further searching revealed this behaviour is initiated at login and overrides the command run at boot. To run this automatically, just add the lines below to the end of the .profile in your Home folder.

# Turn off screen blanking

xset s off && xset -dpms

If you don't see .profile, open your Home folder in your file browser, click on 'View' and select 'Show Hidden Files'. Then just right click on .profile, select 'Open with text editor', copy and paste the above on a blank line at the end of the file and save the modified file.

0

Lubuntu 18.04 LTS: Menu > Preferences > Power Manager > Display tab

hat tip: https://ubuntuforums.org/showthread.php?t=2434603

-1

new versions of Ubuntu is using gnome-screensaver, not xscreensaver. The settings is in System Settings -> Brightness and Lock

2
  • 4
    not true for lubuntu. Jun 24, 2013 at 14:39
  • This is the best answer for ubuntu 14.04
    – ton
    Apr 10, 2016 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.