A bit of a linux noob here, I'm trying to get VMware installed and I've finally gotten to the point where I can leave terminal and do the easy work lol, but now I'm stuck again.

I followed these instructions and when I get to this part where it extracts the folder the installer doesn't open.

Extracting VMware installer

I tried running vmware-modconfig --console --install-all in the terminal but the last line says something like "could not install all modules check log for details"

The last lines of the log file say:

x’ defined but not used [-Wunused-function] 
cc1: some warnings being treated as errors 
make[2]: *** [/tmp/modconfig-exlEke/vmci-only/linux/driver.o] Error 1 
make[2]: *** Waiting for unfinished jobs.... 
make[1]: *** [_module_/tmp/modconfig-exlEke/vmci-only] Error 2 
make[1]: Leaving directory `/usr/src/linux-headers-3.8.0-19-generic' 
make: *** [vmci.ko] Error 2 
make: Leaving directory `/tmp/modconfig-exlEke/vmci-only' 
Unable to install all modules. See log for details.

A user in chat said it looked like a problem with the kernel modules. How can I get VMware Workstation 9 to install under Ubuntu 13.04, kernel 3.8.0-19-generic?

  • Do you have Ubuntu 64bit installed?
    – Mitch
    May 5, 2013 at 8:15
  • Yeah 64bit 13.04
    – Josh
    May 5, 2013 at 8:57
  • 1
    open terminal and type > vmware < update your question with the output and have you install > sudo apt-get install build-essential ?????
    – Qasim
    May 5, 2013 at 9:26
  • !VMware output.
    – Josh
    May 5, 2013 at 9:45
  • That's the output i got. Sorry tried to make the image appear without the link, but not sure if that works in the comments section. And i did not have build-essential installed, but did install it and tried to do the install again and got the same result as before.
    – Josh
    May 5, 2013 at 9:48

2 Answers 2


This solution works for me: http://ubuntuforums.org/showthread.php?t=2107900

launch this script:

if [[ $UID != 0 ]]; then
    echo "Please run this script with sudo:"
    echo "sudo $0 $*"
    exit 1

sudo ln -s /usr/src/linux-headers-$(uname -r)/include/generated/uapi/linux/version.h /usr/src/linux-headers-$(uname -r)/include/linux/version.h

cd /usr/lib/vmware/modules/source
sudo tar -xf vmci.tar
cd vmci-only/linux
sudo sed '127s/.*/   .remove = vmci_remove_device,/' driver.c > driver.c.tmp
mv driver.c.tmp driver.c
sudo sed '1753s/.*/static int/' driver.c > driver.c.tmp
mv driver.c.tmp driver.c
sudo sed '1981s/.*/static void/' driver.c > driver.c.tmp
mv driver.c.tmp driver.c
cd ../..
sudo tar -cf vmci.tar vmci-only/
sudo rm vmci-only/ -Rf
sudo vmware-modconfig --console --install-all
sudo rm /usr/src/linux-headers-$(uname -r)/include/linux/version.h
echo "Done"

After upgrade to 13.04 Vmware stopped working. I removed Vmware Workstation, installed again and run this script upper. Old config is working, old vm's are running :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.