I've imported an OpenVPN configuration file that behaves differently when trying to connect from Network Manager and command line. I would like to see what the imported configuration file looks like.


12.04 onwards

Connection information is stored in the directory:


Note: This directory stores other connection information such as wifi connections.

Pre 12.04

In Kubuntu, network-manager-openvpn-kde saves its profiles to:


In Ubuntu, network-manager-openvpn-gnome saves its profiles to:


(VPN settings are in ~/.gconf/system/networking/connections/*/vpn/%gconf.xml)

  • 2
    Isn't there a way to have it directly use .conf files?
    – Oxwivi
    Mar 5 '11 at 12:48
  • 2
    There is, but it circumvents the network-manager. Place the file in /etc/openvpn/. Make sure it has a .conf suffix, the init script at /etc/init.d/openvpn searches for such files. The VPN will be started at boot time. To disable this, edit /etc/default/openvpn uncomment the AUTOSTART=none line. I'm doing it this way because the network-manager-openvpn is too limited, I cannot run script after connection for example. To start OpenVPN with your configuration file client.conf, run sudo /etc/init.d/openvpn start client. To stop it, run /etc/init.d/openvpn stop client.
    – Lekensteyn
    Mar 5 '11 at 13:11
  • 4
    It seems this answer is no longer up-to-date as of Ubuntu 12.04. I have a couple VPNs configured through Network Manager in 12.04 using network-manager-openvpn-gnome, but there is no ~/.gconf/system directory. Anyone know where those files might live nowadays?
    – Carl Meyer
    May 2 '12 at 15:44
  • @CarlMeyer Try importing and run the command find ~ -mmin -3 -ls to find all modified files in the last 3 minutes.
    – Lekensteyn
    May 2 '12 at 15:47
  • 6
    Turns out they are stored in /etc/NetworkManager/system-connections/ (even when they aren't shared with everyone)
    – boatcoder
    Jun 22 '12 at 22:36

Yes, in Ubuntu 12.04 and later the config settings are stored in /etc/NetworkManager/system-connections -- except, when someone didn't migrate the connection information out of an older .conf file and continued using that .conf file instead. In that case, the settings are in /home/USER/.gcm/gcm.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.