First of all, I'm pretty new in Ubuntu so I don't know everything.. But I'm willing to learn!

Today I updated my ubuntu to 13.04. Everything seemed fine. I used my pc for an hour and shut it down. The next time I tried to boot it up, unity won't start. I tried to start unity by terminal but it gives me several errors:

Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Compiz (opengl) - Fatal: glXQueryExtensionsString is NULL for screen 0

I started searching and tried to remove and install the nvidia drivers by using this:

sudo apt-get remove nvidia-current sudo apt-get install nvidia-current

I rebooted but still unity won't start up. I tried several things found here on askubuntu, but it seems nothing is working. Yet I found something to test if unity is supported:

/usr/lib/nux/unity_support_test -p

Which gave me this output:

Xlib: extension "GLX" missing on display ":0.0". Error: GLX is not available on the system

Some information about my Nvidia card (using: lspci | grep VGA):

00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2)

02:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 8400 GS Rev. 2] (rev a1)

Is there anyone who has had this problem as well and solved it?

Thanks in advance,


1 Answer 1


Had same issue with NVIDIA GeForce GT 425M card. I kept seeing messages via

dmesg | grep -i nvidia

about the nvidia drivers tainting the kernel.

Eventually, I tried

sudo apt-get remove ^nvidia

then rebooted.

Next I ran

ccsm &

and enabled first OpenGL, then Scale, then Expo, closing and re-running ccsm & after each selection.

Finally on the last execution of ccsm, I enabled the Ubuntu Unity Plugin.

At last, the Dash and Launcher appeared.

Seems like the answer was to drive out NVIDIA completely with the asterisk after nvidia in the sudo apt-get remove command.

Good luck with repairing your configuration.


  • FYI, apt-get remove nvidia* will remove all packages containing the word nvidi. The command that removes all packages starting with nvidia is apt-get remove ^nvidia Aug 24, 2013 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.