I upgraded from ubuntu 12.10 to 13.04 on a laptop running an ATI RV635 [Mobility Radeon HD 3650] graphics card. After the update the screen was garbled. If I get into ubuntu via the ubuntu recovery console (network enabled option) I can log in but then see no Unity or decorated windows.

When I upgraded from 12.04 to 12.10 I had to follow the instructions at http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html to use my display but these didn't work for 13.04 and I undid them.

Can someone please help me fix this display issue so I can use 13.04? The Software Center says the open source driver xserver-xorg-video-radeon is installed so I don't know why that doesn't appear to be working.


Makarewicz' PPA downgrades xorg to 1.12? I imagine it must downgrade a bunch of dependencies as well, and I'm sure it becomes more difficult with each Ubuntu release. Unixmen recommended installing a legacy Catalyst driver without downgrading xorg, though they also recommend Makarewicz' PPA. Something's not right here, but that lighter touch seems more likely to work as continued Ubuntu releases move farther away from no longer supported hardware. Unixmen's lighter touch can be found here. I don't have an affected Radeon card so I can't vouch for any of this.

  • Thanks for your help. I'm trying out grimpitch's ideas first. However, the solution at your Unixmen link mentions the same PPA steps I did before (sudo add-apt-repository ppa:makson96/fglrx, etc) and that definitely downgraded xorg to 1.12, which doesn't match what Unixmen say about keeping it at 1.13! Anyway, if I can't get any joy with grimpitch's ideas I might try running that AMD driver installer script mentioned on the Unixmen site instead... – snark May 4 '13 at 17:47
  • I took a look at unixmen.com/ubuntu-12-10-and-amd-catalyst-problem-solved and help.ubuntu.com/community/BinaryDriverHowto/… and applied the same steps to the more recent www2.ati.com/drivers/legacy/… driver but using --buildpkg Ubuntu/raring. On rebooting however I still didn't get Unity; fglrxinfo still reported the same error as below; and appreport triggered me to report a new bug: bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1176441 – snark May 4 '13 at 22:42
  • My bug was made a duplicate of Bug #1058040 which won't be fixed. Oh well; back to ubuntu 12.10 then... – snark May 5 '13 at 20:38
  • I successfully reinstalled ubuntu 12.04 in the end - thought it made more sense to go to a LTS. No probs with my display there:). – snark May 6 '13 at 11:10

It should simply work with the distro version of the fglrx driver, the xserver-xorg-video-radeon driver provides 2D support only (leave it installed). If you can get a terminal, run sudo apt-get install fglrx. You will also need the kernel headers, if you don't have it already installed. Also check the output of the fglrxinfo command.

  • Thanks for your help grimpitch. I ran sudo apt-get install fglrx. It appeared to work ok and then I rebooted. But if I go back into ubuntu recovery mode it forces me to use low graphics and there's still no Unity. In a terminal fglrrxinfo says (paraphrasing because I'm on a different computer): BadRequest... Major opcode: 153 (GLX)... Minor opcode: 19 (X_GLXQueryServerString)... Serial number of failed request: 12. Current serial number in output stream: 12 What next do you think? – snark May 4 '13 at 17:39
  • What happens if you boot normally now? (not recovery mode) – grimpitch May 4 '13 at 18:24
  • I get a warning dialog: "The system is running in low-graphics mode. Your screen, graphics card, and input device settings could not be detected correctly. You will need to configure these yourself". I click OK. New dialog: "What would you like to do?" Only 1 option is selected: "Run in low-graphics mode for just one session." Click OK. I get a simplified login screen. Login. I get my regular backdrop image, although in lower than normal resolution. I can right-click on the desktop and open a terminal. But no Unity and the terminal window is not decorated. fglrxinfo reports the same as before. – snark May 4 '13 at 20:50
  • 2
    I have read a few guides on the net, unfortunately...it seems like the up to date fglrx driver doesn't support the HD 2000/3000/4000 type of GPUs anymore. The older driver (13.1) that supports this GPU class doesn't support the kernels above version 3.4, and the currently used xorg server(1.13). The only way is the downgrade with the makson96 PPA, because AMD doesn't update the legacy drivers. – grimpitch May 4 '13 at 23:14
  • Thanks grimpitch. Unfortunately the makson96 PPA doesn't work either - still no Unity or decorated windows. Thanks for your help but I will probably revert to ubuntu 12.10. Hopefully AMD will update their Catalyst display driver to support a more recent kernel. Then it might be possible for me to upgrade to 13.04 successfully. – snark May 5 '13 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.