1

Good evening Everyone, I am having problems recovering my desktop.

Before it came to this desktop without the taskbar at the top, and the sidebar. Also the title bar for applications are gone.

What happened is I tried to installed my NVIDIA driver without using the AdditionalDrivers application, but using the terminal.

  1. I downloaded the installer for my NVIDIA driver
  2. Followed the instructions, which was first to disable the X server, I did it by changing the run-level.

    vim /etc/init/rc-sysinit.conf
    changed the value of "env DEFAULT_RUNLEVEL = 2" to 3

  3. Next was I disable the Nouveau Driver by adding this lines.

    blacklist nouveau
    options nouveau modeset=0

    to the following file: /etc/modprobe.d/blacklist.conf using vim

After that everything went wrong, my desktop did not went the way things I thought it would be so, I decided to uninstall the driver and undo the changes I did.. and this happened..

The reason why I tried to install the driver: because my systems keeps on saying my graphics driver is not well configured that I had to run on low graphics mode for one session even if it won't be just once. and also it keeps giving errors that my graphics is not well installed. hmp..

Before everything else, my desktop was fine. I was looking for some ways to reset the default desktop unity which was

unity reset

but it gives out an error that the reset command was already deprecated and so I came to my last resort on posting a question in this forum so I can find a solution on how to fix my desktop environment.

My desktop right now

I'm using the Ubuntu 12.10 Desktop version btw.

I can't run the unity command in the terminal. It gives out errors that the process is not found and all the things that it is loading goes for an error and nothing.

If definitely by chance I get things done and found the solution, I'll post it.

0

Switch to a console (not a terminal!) by using Ctrl + Alt + F1

dpkg-reconfigure compiz 
compiz --replace
unity --reset
unity --replace

Switch back to your desktop with Ctrl + Alt + F7.

Maybe a reboot of the system is necessary.

  • nothing happened my desktop is still the same though.. haven't really found one user who has the same problem as I am.. hmp.. If I install another desktop environment?.. or reinstall the unity desktop environment?.. would it make things better?.. – Softmaven May 4 '13 at 14:29
  • Take a look at the +50 answer in this question: askubuntu.com/questions/128676/… – sinclair May 4 '13 at 14:56
  • still nothing.. – Softmaven May 4 '13 at 15:12
  • I also tried some of the solutions here: askubuntu.com/questions/17381/… still nothing happened.. – Softmaven May 4 '13 at 15:28
  • Try to start "ccsm", check if the unity plugin is available/active. Then take a look at the "window" section. Maybe disable/enable some values will reset the config. – sinclair May 4 '13 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.