1

I am trying to compile some OpenGL apps from sources but there is no /usr/lib/libGL.so, or /usr/lib/libGL.so.1 or even /usr/lib/libGL.so.1.2. However fglrxinfo says:

display: :0.0 screen: 0 OpenGL vendor string: ATI Technologies Inc. OpenGL renderer string: ATI Mobility Radeon HD 4500 Series OpenGL version string: 3.3.10237 Compatibility Profile Context

Which is what i espect and the gears demo also works...

How do i get those files? I tried the MESA files and then i got SW rendering which is not what i want...

0

The libgl1-dev package is a meta-package that contains the required lib and can be replaced with software implementations libgl1-mesa-swx11 or dri accelerated version libgl1-mesa-dri.

-1

The fglrx package contains /usr/lib/fglrx/libGL.so

To see which libs glxgears (or any other program) is using use

ldd "$(which glxgears)"
  • I could do that but it would make my binaries to link only against the libs on my machine, if i run those on a intel or nvidia environment it would not work. – Paulo Lopes Mar 13 '11 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.